aboutsummaryrefslogtreecommitdiffstats
path: root/games/glest/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-05-12 18:11:40 +0800
committeritetcu <itetcu@FreeBSD.org>2006-05-12 18:11:40 +0800
commit1f4069d6396cdef90c5242d9d313a4b1b46f489f (patch)
tree58c33acdf88802c4b924901b9dc6170f5ef3a253 /games/glest/Makefile
parent247b789c958c5fc566c1381be85a3f53775103f6 (diff)
downloadfreebsd-ports-gnome-1f4069d6396cdef90c5242d9d313a4b1b46f489f.tar.gz
freebsd-ports-gnome-1f4069d6396cdef90c5242d9d313a4b1b46f489f.tar.zst
freebsd-ports-gnome-1f4069d6396cdef90c5242d9d313a4b1b46f489f.zip
Update to 2.0.0
I separeted glest port to glest and glest-data ports. Glest 2.0.0 has been released, this version includes loads of new features: - New Magic units: - Tower of Souls: Air defense building, attacks air only - Golem: Defensive unit, needs EP to walk, can't attack air - Daemon giant: Heavy melee unit - Drake rider: Light ranged unit - New Tech units: - Aerodrome: Building for producing air units - Air ballista: Air defense building, attacks air only - Rider: Fast medium unit - Ornithopter: Light air unit - Airship: Heavy air unit, can't attack air - New Magic upgrades - New Tech upgrades - New animations for existing units - Shared vision between allies - New particle blending - Felix and Matze added to the credits - Players now start on the location indicated in the game settings menu - Score system - HTML documentation - Increased projectile accuracy - Optimized particle rendering - Loads of balance changes PR: ports/95608 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> (maintainer) Approved by: lawrance (mentor)
Diffstat (limited to 'games/glest/Makefile')
-rw-r--r--games/glest/Makefile34
1 files changed, 12 insertions, 22 deletions
diff --git a/games/glest/Makefile b/games/glest/Makefile
index d0e34e3c7e27..44ffad871f21 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= glest
-PORTVERSION= 1.2.1.2
-PORTREVISION= 1
+PORTVERSION= 2.0.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${PORTNAME}_source_${PORTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}_data_1.2.1${EXTRACT_SUFX}
+DISTNAME= ${PORTNAME}_source_${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acardenas@bsd.org.pe
COMMENT= Free 3d real-time customizable strategy game
@@ -22,6 +21,7 @@ LIB_DEPENDS= xerces-c.26:${PORTSDIR}/textproc/xerces-c2 \
openal.0:${PORTSDIR}/audio/openal \
alut.0:${PORTSDIR}/audio/freealut
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+RUN_DEPENDS= ${X11BASE}/lib/${PORTNAME}/configuration.xml:${PORTSDIR}/games/glest-data
USE_X_PREFIX= yes
USE_AUTOTOOLS= automake:15:env autoconf:259:env
@@ -35,22 +35,20 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-WRKSRC= ${WRKDIR}/${PORTNAME}_source_${PORTVERSION}
-
-GLESTDIRE= ${PREFIX}/lib/${PORTNAME}
+GLESTDIRE= lib/${PORTNAME}
+PLIST_SUB= GLESTDIRE=${GLESTDIRE}
SUB_FILES= glest-wrapper
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-IGNORE= "does not build on 4.x"
+IGNORE= does not build on 4.x
.endif
post-extract:
@${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|cpp|h|txt|sh|ac|sub|ini|m4|jam|guess|rpath)" \
-print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
- @${RM} ${WRKDIR}/${PORTNAME}_game/glest.ini
post-patch:
@${REINPLACE_CMD} -e "s|%%ACLOCAL%%|${ACLOCAL}|g" -e "s|%%AUTOCONF%%|${AUTOCONF}|g" \
@@ -70,24 +68,16 @@ do-build:
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_game/license.txt ${DOCSDIR}/license-data.txt
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_game/readme.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/license.txt ${DOCSDIR}/license-game.txt
.endif
- @${RM} ${WRKDIR}/${PORTNAME}_game/license.txt
- @${RM} ${WRKDIR}/${PORTNAME}_game/readme.txt
- @${MKDIR} ${GLESTDIRE}
- @${INSTALL_PROGRAM} ${WRKSRC}/glest ${GLESTDIRE}
- @${INSTALL_DATA} ${WRKSRC}/mk/linux/glest.ini ${GLESTDIRE}
- @${INSTALL_SCRIPT} ${WRKDIR}/glest-wrapper ${PREFIX}/bin/glest
- @cd ${WRKDIR}/${PORTNAME}_game && \
- ${FIND} * -type d -exec ${MKDIR} "${GLESTDIRE}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${GLESTDIRE}/{}" \;
+ ${MKDIR} ${PREFIX}/${GLESTDIRE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/glest ${PREFIX}/${GLESTDIRE}
+ ${INSTALL_DATA} ${WRKSRC}/mk/linux/glest.ini ${PREFIX}/${GLESTDIRE}
+ ${INSTALL_SCRIPT} ${WRKDIR}/glest-wrapper ${PREFIX}/bin/glest
post-install:
- @${CHMOD} 666 ${GLESTDIRE}/glest.log
@${ECHO_MSG}
- @${ECHO_MSG} "* Configuration file ${GLESTDIRE}/glest.ini"
+ @${ECHO_MSG} "* Configuration file ${PREFIX}/${GLESTDIRE}/glest.ini"
@${ECHO_MSG}
.include <bsd.port.post.mk>