aboutsummaryrefslogtreecommitdiffstats
path: root/games/gno3dtet/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-27 01:07:53 +0800
committerpav <pav@FreeBSD.org>2005-11-27 01:07:53 +0800
commite2a774f40658641846b5a7c6228e02c7877c2760 (patch)
tree629bbaeded3fbef9034894d306933a4b6798ce4d /games/gno3dtet/Makefile
parent0aef8f31c257db0a7cbd831532617644e2b6478e (diff)
downloadfreebsd-ports-gnome-e2a774f40658641846b5a7c6228e02c7877c2760.tar.gz
freebsd-ports-gnome-e2a774f40658641846b5a7c6228e02c7877c2760.tar.zst
freebsd-ports-gnome-e2a774f40658641846b5a7c6228e02c7877c2760.zip
- Update to 1.96.1
PR: ports/89577 Submitted by: Ports Fury
Diffstat (limited to 'games/gno3dtet/Makefile')
-rw-r--r--games/gno3dtet/Makefile38
1 files changed, 26 insertions, 12 deletions
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index 90a1b6ba98ec..fb10654ff9aa 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -6,29 +6,43 @@
#
PORTNAME= gno3dtet
-PORTVERSION= 1.6.4
-PORTREVISION= 1
+PORTVERSION= 1.96.1
CATEGORIES= games gnome
-MASTER_SITES= ftp://12.206.131.3/pub/gno3dtet/ \
- http://www.eseb.net/ftp/gno3dtet/
+MASTER_SITES= http://eseb.net/ftp/gno3dtet/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME version of the classic 3D-ified T*tris
-USE_REINPLACE= yes
+EXTRACT_DEPENDS=intltoolize:${PORTSDIR}/textproc/intltool
+
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui librsvg2
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= autoheader:259 automake:19 aclocal:19 autoconf:259
+ACLOCAL_ARGS= -I m4 -I ${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= -a -c -f
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_OMF= yes
+
+run-autotools:: run-autotools-aclocal run-autotools-autoheader \
+ run-autotools-automake run-autotools-autoconf
+
+post-extract:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/intltoolize -c -f
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/LIBTOOL/d ; \
+ s|gnome-games|gno3dtet|g' ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e 's|/gnome/help/|/help/|g' \
+ ${WRKSRC}/xmldocs.make
+ @${REINPLACE_CMD} -e 's|/gnome/help/|/help/|g ; \
+ s|datadir)/locale|prefix)/share/locale|g' ${WRKSRC}/src/Makefile.am
+
+pre-configure:
+ @${INSTALL_SCRIPT} ${AUTOMAKE_DIR}/mkinstalldirs ${WRKSRC}
post-install:
${CHOWN} root:games ${PREFIX}/bin/gno3dtet