aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnocatan/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-06-23 04:49:49 +0800
committerade <ade@FreeBSD.org>2000-06-23 04:49:49 +0800
commitaed106fae5b9ef28003ccf423f52bc9dac2c9528 (patch)
tree1eafbab71f9536183860f8215fe97f8288313f4f /games/gnocatan/Makefile
parent364ef9a86715231c0d872953807153295984ec28 (diff)
downloadfreebsd-ports-gnome-aed106fae5b9ef28003ccf423f52bc9dac2c9528.tar.gz
freebsd-ports-gnome-aed106fae5b9ef28003ccf423f52bc9dac2c9528.tar.zst
freebsd-ports-gnome-aed106fae5b9ef28003ccf423f52bc9dac2c9528.zip
Gnocatan is an Internet playable implementation of the Settlers of
Catan board game. The aim is to remain as faithful to the board game as is possible. Requested by: Thomas Schuerger <schuerge@wjpserver.CS.Uni-SB.DE>
Diffstat (limited to 'games/gnocatan/Makefile')
-rw-r--r--games/gnocatan/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/gnocatan/Makefile b/games/gnocatan/Makefile
new file mode 100644
index 000000000000..470a0f1bf4bf
--- /dev/null
+++ b/games/gnocatan/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gnocotan
+# Date created: 22nd July 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnocatan
+PORTVERSION= 0.6.0
+CATEGORIES= games gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>