aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnome-games/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-10-02 08:58:05 +0800
committervanilla <vanilla@FreeBSD.org>1998-10-02 08:58:05 +0800
commita53fe499941f0aa07fa36d6bf5c8e0335f901956 (patch)
treea3f5e8a56e4621ada0096fba5ca42ce18ee758e3 /games/gnome-games/Makefile
parent5e8e859250b59e92284d9398d8ebe3d23890955c (diff)
downloadfreebsd-ports-gnome-a53fe499941f0aa07fa36d6bf5c8e0335f901956.tar.gz
freebsd-ports-gnome-a53fe499941f0aa07fa36d6bf5c8e0335f901956.tar.zst
freebsd-ports-gnome-a53fe499941f0aa07fa36d6bf5c8e0335f901956.zip
Import gnomegames, It's gnome game app.
PR: ports/7656 Reviewed by: vanilla Submitted by: Yukihiro Nakai <Nakai@technogilist.com>
Diffstat (limited to 'games/gnome-games/Makefile')
-rw-r--r--games/gnome-games/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
new file mode 100644
index 000000000000..fb8cae7247e2
--- /dev/null
+++ b/games/gnome-games/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnomegames
+# Version required: 0.30
+# Date created: 03 July 1998
+# Whom: Yukihiro Nakai <Nakai@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= gnome-games-0.30
+PKGNAME= gnomegames-0.30
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
+ ftp://ftp.gnome.org/pub/GNOME/sources/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomecore
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-gnome=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>