aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnome-games
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-12-19 02:59:46 +0800
committermarcus <marcus@FreeBSD.org>2002-12-19 02:59:46 +0800
commit555aec1930457366a47f35a2d6a7d2742156088e (patch)
tree3a10f816043bf8ec498821944ff1bd8b4928e8c0 /games/gnome-games
parent6a8c8cb67e1dced7527fcd6ea14e4de53a9f45f5 (diff)
downloadfreebsd-ports-gnome-555aec1930457366a47f35a2d6a7d2742156088e.tar.gz
freebsd-ports-gnome-555aec1930457366a47f35a2d6a7d2742156088e.tar.zst
freebsd-ports-gnome-555aec1930457366a47f35a2d6a7d2742156088e.zip
Fix the install and plist on -CURRENT.
Reported by: walt <wa1ter@myrealbox.com>
Diffstat (limited to 'games/gnome-games')
-rw-r--r--games/gnome-games/Makefile5
-rw-r--r--games/gnome-games/pkg-plist46
2 files changed, 51 insertions, 0 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index c66c3fef8de2..3081dc591d01 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomegames2
PORTVERSION= 2.0.6
+PORTREVISION= 1
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-games/2.0
@@ -35,5 +36,9 @@ post-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|games\.games|games:games|g ; \
+ s|[(]GCONF_CONFIG_SOURCE[)]|(GCONF_SCHEMA_CONFIG_SOURCE)|g'
+
.include <bsd.port.mk>
diff --git a/games/gnome-games/pkg-plist b/games/gnome-games/pkg-plist
index 6b2310932a98..910edff0181e 100644
--- a/games/gnome-games/pkg-plist
+++ b/games/gnome-games/pkg-plist
@@ -16,6 +16,29 @@ bin/iagno
bin/mahjongg
bin/same-gnome
bin/sol
+etc/gconf/gconf.xml.defaults/apps/freecell/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/freecell/option/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/freecell/score/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnometris/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnometris/options/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnomine/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gnomine/geometry/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gtali/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/iagno/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/mahjongg/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/same-gnome/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/freecell/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/freecell/option/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/freecell/score/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gataxx/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnometris/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnometris/options/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnomine/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gnomine/geometry/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gtali/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/iagno/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mahjongg/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/same-gnome/%gconf.xml
etc/gconf/schemas/freecell.schemas
etc/gconf/schemas/gataxx.schemas
etc/gconf/schemas/gnect.schemas
@@ -738,3 +761,26 @@ share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
@dirrm share/gnome/help/glines/C/figures
@dirrm share/gnome/help/glines/C
@dirrm share/gnome/help/glines
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/same-gnome
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mahjongg
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/iagno
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gtali
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnomine/geometry
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnomine
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gataxx
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/freecell/score
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/freecell/option
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/freecell
+@dirrm etc/gconf/gconf.xml.defaults/apps/same-gnome
+@dirrm etc/gconf/gconf.xml.defaults/apps/mahjongg
+@dirrm etc/gconf/gconf.xml.defaults/apps/iagno
+@dirrm etc/gconf/gconf.xml.defaults/apps/gtali
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnomine/geometry
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnomine
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnometris/options
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gnometris
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnometris/options
+@dirrm etc/gconf/gconf.xml.defaults/apps/gnometris
+@dirrm etc/gconf/gconf.xml.defaults/apps/freecell/score
+@dirrm etc/gconf/gconf.xml.defaults/apps/freecell/option
+@dirrm etc/gconf/gconf.xml.defaults/apps/freecell