aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnome-games
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
committermarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
commit0b42143dea1a55d0f1f6d09704bbc131e1b633ed (patch)
treebc54902eb18f738e45a91362b2b0faf1ec6d04fa /games/gnome-games
parent773c9ca4ac44ac67652d01f1e985e4df8dab5301 (diff)
downloadfreebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.gz
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.zst
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Diffstat (limited to 'games/gnome-games')
-rw-r--r--games/gnome-games/Makefile25
-rw-r--r--games/gnome-games/distinfo4
-rw-r--r--games/gnome-games/files/patch-iagno_othello.c21
-rw-r--r--games/gnome-games/pkg-install2
-rw-r--r--games/gnome-games/pkg-plist130
5 files changed, 142 insertions, 40 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index eba339873a13..b36d2def0e2d 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gnomegames2
-PORTVERSION= 2.8.3
+PORTVERSION= 2.10.0
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-games/2.8
+MASTER_SITE_SUBDIR= sources/gnome-games/2.10
DISTNAME= gnome-games-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,11 +19,12 @@ COMMENT= The game applications package for the Gnome 2 Desktop Environment
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_PYTHON= yes
INSTALLS_OMF= yes
+USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier intlhack libgnomeui \
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui \
librsvg2 desktopfileutils
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -32,16 +33,24 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= aisleriot.schemas blackjack.schemas gataxx.schemas \
glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas \
gnome-stones.schemas gnometris.schemas gnomine.schemas \
- gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas \
- same-gnome.schemas
+ gnotravex.schemas gnotski.schemas gtali.schemas iagno.schemas \
+ libgnomegames.schemas mahjongg.schemas same-gnome.schemas
CONFLICTS= sol-1.0.*
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libhowl.so) || defined(WITH_MDNS)
+LIB_DEPENDS+= howl:${PORTSDIR}/net/howl
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+ @${REINPLACE_CMD} -e 's|bin/python|bin/env python|g' \
+ ${WRKSRC}/libgames-support/games-server.py
post-install:
- @-update-desktop-database > /dev/null
+ @-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/gnome-games/distinfo b/games/gnome-games/distinfo
index 2104d853d2e5..504bc5c7fce3 100644
--- a/games/gnome-games/distinfo
+++ b/games/gnome-games/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-games-2.8.3.tar.bz2) = 0ee8f7cb3a95a5e69a7c9cbb4dc6c66a
-SIZE (gnome2/gnome-games-2.8.3.tar.bz2) = 5923240
+MD5 (gnome2/gnome-games-2.10.0.tar.bz2) = c3a1a8fd025a0174efa70d4e480114cf
+SIZE (gnome2/gnome-games-2.10.0.tar.bz2) = 5292770
diff --git a/games/gnome-games/files/patch-iagno_othello.c b/games/gnome-games/files/patch-iagno_othello.c
index 84b963a911e2..1d6d8e88a6a7 100644
--- a/games/gnome-games/files/patch-iagno_othello.c
+++ b/games/gnome-games/files/patch-iagno_othello.c
@@ -1,29 +1,20 @@
---- iagno/othello.c.orig Mon Feb 14 12:07:12 2005
-+++ iagno/othello.c Mon Feb 14 12:07:47 2005
-@@ -551,7 +551,7 @@
- memcpy (tboard, board, sizeof (gint8) * 8 * 8);
- move_board(tboard, i, j, me, 0);
-
-- // assume that opponent takes best move
-+ /* assume that opponent takes best move */
- tmp_move = find_best_move(tboard, not_me, ply_depth-1,
- -pass_thresh, -use_thresh, 0, 0);
-
-@@ -808,14 +808,14 @@
+--- iagno/othello.c.orig Tue Jan 25 11:24:35 2005
++++ iagno/othello.c Tue Jan 25 11:24:56 2005
+@@ -784,14 +784,14 @@
found_free = TRUE;
}
- // check if a player is dead
+ /* check if a player is dead */
if (!found_me && found_not_me)
- return (-10000);
+ return (S_LOSING_GAME);
else if (found_me && !found_not_me)
- return (10000);
+ return (S_WINNING_GAME);
- // if the game is finished, return the actual score rather than
- // a huristic
+ /* if the game is finished, return the actual score rather than
-+ a huristic */
++ * a huristic */
if (!found_free)
return (actual_score);
diff --git a/games/gnome-games/pkg-install b/games/gnome-games/pkg-install
index da897732169d..7b1b35161239 100644
--- a/games/gnome-games/pkg-install
+++ b/games/gnome-games/pkg-install
@@ -5,7 +5,7 @@ PATH=/bin:/usr/bin:/usr/sbin
case $2 in
POST-INSTALL)
mkdir -p ${PKG_PREFIX}/share/gnome/games
- SCORES="glines.scores gnibbles.1.0.scores gnibbles.1.1.scores gnibbles.2.0.scores gnibbles.2.1.scores gnibbles.3.0.scores gnibbles.3.1.scores gnibbles.4.0.scores gnibbles.4.1.scores gnobots2.classic_robots-safe.scores gnobots2.classic_robots-super-safe.scores gnobots2.classic_robots.scores gnobots2.nightmare-safe.scores gnobots2.nightmare-super-safe.scores gnobots2.nightmare.scores gnobots2.robots2-safe.scores gnobots2.robots2-super-safe.scores gnobots2.robots2.scores gnobots2.robots2_easy-safe.scores gnobots2.robots2_easy-super-safe.scores gnobots2.robots2_easy.scores gnobots2.robots_with_safe_teleport-safe.scores gnobots2.robots_with_safe_teleport-super-safe.scores gnobots2.robots_with_safe_teleport.scores gnome-stones.scores gnometris.scores gnomine.Custom.scores gnomine.Large.scores gnomine.Medium.scores gnomine.Small.scores gnotravex.2x2.scores gnotravex.3x3.scores gnotravex.4x4.scores gnotravex.5x5.scores gnotravex.6x6.scores gnotski.1.scores gnotski.11.scores gnotski.12.scores gnotski.13.scores gnotski.14.scores gnotski.15.scores gnotski.16.scores gnotski.17.scores gnotski.2.scores gnotski.21.scores gnotski.22.scores gnotski.23.scores gnotski.24.scores gnotski.25.scores gnotski.26.scores gnotski.3.scores gnotski.4.scores gnotski.5.scores gnotski.6.scores gnotski.7.scores gtali.scores mahjongg.bridges.scores mahjongg.cloud.scores mahjongg.confounding.scores mahjongg.difficult.scores mahjongg.dragon.scores mahjongg.easy.scores mahjongg.pyramid.scores mahjongg.tictactoe.scores mahjongg.ziggurat.scores same-gnome.scores"
+ SCORES="glines.scores gnibbles.1.0.scores gnibbles.1.1.scores gnibbles.2.0.scores gnibbles.2.1.scores gnibbles.3.0.scores gnibbles.3.1.scores gnibbles.4.0.scores gnibbles.4.1.scores gnobots2.classic_robots-safe.scores gnobots2.classic_robots-super-safe.scores gnobots2.classic_robots.scores gnobots2.nightmare-safe.scores gnobots2.nightmare-super-safe.scores gnobots2.nightmare.scores gnobots2.robots2-safe.scores gnobots2.robots2-super-safe.scores gnobots2.robots2.scores gnobots2.robots2_easy-safe.scores gnobots2.robots2_easy-super-safe.scores gnobots2.robots2_easy.scores gnobots2.robots_with_safe_teleport-safe.scores gnobots2.robots_with_safe_teleport-super-safe.scores gnobots2.robots_with_safe_teleport.scores gnome-stones.scores gnometris.scores gnomine.Custom.scores gnomine.Large.scores gnomine.Medium.scores gnomine.Small.scores gnotravex.2x2.scores gnotravex.3x3.scores gnotravex.4x4.scores gnotravex.5x5.scores gnotravex.6x6.scores gnotski.1.scores gnotski10.scores gnotski.11.scores gnotski.12.scores gnotski.13.scores gnotski.14.scores gnotski.15.scores gnotski.16.scores gnotski.17.scores gnotski.18.scores gnotski.2.scores gnotski.20.scores gnotski.21.scores gnotski.22.scores gnotski.23.scores gnotski.24.scores gnotski.25.scores gnotski.26.scores gnotski.27.scores gnotski.28.scores gnotski.29.scores gnotski.3.scores gnotski.30.scores gnotski.31.scores gnotski.32.scores gnotski.33.scores gnotski.34.scores gnotski.35.scores gnotski.36.scores gnotski.37.score gnotski.4.scores gnotski.5.scores gnotski.6.scores gnotski.7.scores gnotski.8.scores gnotski.9.scores gtali.scores mahjongg.bridges.scores mahjongg.cloud.scores mahjongg.confounding.scores mahjongg.difficult.scores mahjongg.dragon.scores mahjongg.easy.scores mahjongg.pyramid.scores mahjongg.tictactoe.scores mahjongg.ziggurat.scores same-gnome.scores"
for i in ${SCORES}; do
if [ ! -f ${PKG_PREFIX}/share/gnome/games/${i} ]; then
touch -f ${PKG_PREFIX}/share/gnome/games/${i}
diff --git a/games/gnome-games/pkg-plist b/games/gnome-games/pkg-plist
index 6df66145aa97..18e3c7765d79 100644
--- a/games/gnome-games/pkg-plist
+++ b/games/gnome-games/pkg-plist
@@ -1,4 +1,5 @@
bin/blackjack
+bin/games-server.py
bin/gataxx
bin/glines
bin/gnect
@@ -14,7 +15,6 @@ bin/iagno
bin/mahjongg
bin/same-gnome
bin/sol
-etc/sound/events/gnect.soundlist
etc/sound/events/gnibbles.soundlist
etc/sound/events/gnobots2.soundlist
etc/sound/events/iagno.soundlist
@@ -78,6 +78,7 @@ share/gnome/blackjack/Vegas_Strip.rules
@unexec [ -s %D/share/gnome/games/gnotravex.5x5.scores ] || rm -f %D/share/gnome/games/gnotravex.5x5.scores
@unexec [ -s %D/share/gnome/games/gnotravex.6x6.scores ] || rm -f %D/share/gnome/games/gnotravex.6x6.scores
@unexec [ -s %D/share/gnome/games/gnotski.1.scores ] || rm -f %D/share/gnome/games/gnotski.1.scores
+@unexec [ -s %D/share/gnome/games/gnotski.10.scores ] || rm -f %D/share/gnome/games/gnotski.10.scores
@unexec [ -s %D/share/gnome/games/gnotski.11.scores ] || rm -f %D/share/gnome/games/gnotski.11.scores
@unexec [ -s %D/share/gnome/games/gnotski.12.scores ] || rm -f %D/share/gnome/games/gnotski.12.scores
@unexec [ -s %D/share/gnome/games/gnotski.13.scores ] || rm -f %D/share/gnome/games/gnotski.13.scores
@@ -85,18 +86,34 @@ share/gnome/blackjack/Vegas_Strip.rules
@unexec [ -s %D/share/gnome/games/gnotski.15.scores ] || rm -f %D/share/gnome/games/gnotski.15.scores
@unexec [ -s %D/share/gnome/games/gnotski.16.scores ] || rm -f %D/share/gnome/games/gnotski.16.scores
@unexec [ -s %D/share/gnome/games/gnotski.17.scores ] || rm -f %D/share/gnome/games/gnotski.17.scores
+@unexec [ -s %D/share/gnome/games/gnotski.18.scores ] || rm -f %D/share/gnome/games/gnotski.18.scores
+@unexec [ -s %D/share/gnome/games/gnotski.19.scores ] || rm -f %D/share/gnome/games/gnotski.19.scores
@unexec [ -s %D/share/gnome/games/gnotski.2.scores ] || rm -f %D/share/gnome/games/gnotski.2.scores
+@unexec [ -s %D/share/gnome/games/gnotski.20.scores ] || rm -f %D/share/gnome/games/gnotski.20.scores
@unexec [ -s %D/share/gnome/games/gnotski.21.scores ] || rm -f %D/share/gnome/games/gnotski.21.scores
@unexec [ -s %D/share/gnome/games/gnotski.22.scores ] || rm -f %D/share/gnome/games/gnotski.22.scores
@unexec [ -s %D/share/gnome/games/gnotski.23.scores ] || rm -f %D/share/gnome/games/gnotski.23.scores
@unexec [ -s %D/share/gnome/games/gnotski.24.scores ] || rm -f %D/share/gnome/games/gnotski.24.scores
@unexec [ -s %D/share/gnome/games/gnotski.25.scores ] || rm -f %D/share/gnome/games/gnotski.25.scores
@unexec [ -s %D/share/gnome/games/gnotski.26.scores ] || rm -f %D/share/gnome/games/gnotski.26.scores
+@unexec [ -s %D/share/gnome/games/gnotski.27.scores ] || rm -f %D/share/gnome/games/gnotski.27.scores
+@unexec [ -s %D/share/gnome/games/gnotski.28.scores ] || rm -f %D/share/gnome/games/gnotski.28.scores
+@unexec [ -s %D/share/gnome/games/gnotski.29.scores ] || rm -f %D/share/gnome/games/gnotski.29.scores
@unexec [ -s %D/share/gnome/games/gnotski.3.scores ] || rm -f %D/share/gnome/games/gnotski.3.scores
+@unexec [ -s %D/share/gnome/games/gnotski.30.scores ] || rm -f %D/share/gnome/games/gnotski.30.scores
+@unexec [ -s %D/share/gnome/games/gnotski.31.scores ] || rm -f %D/share/gnome/games/gnotski.31.scores
+@unexec [ -s %D/share/gnome/games/gnotski.32.scores ] || rm -f %D/share/gnome/games/gnotski.32.scores
+@unexec [ -s %D/share/gnome/games/gnotski.33.scores ] || rm -f %D/share/gnome/games/gnotski.33.scores
+@unexec [ -s %D/share/gnome/games/gnotski.34.scores ] || rm -f %D/share/gnome/games/gnotski.34.scores
+@unexec [ -s %D/share/gnome/games/gnotski.35.scores ] || rm -f %D/share/gnome/games/gnotski.35.scores
+@unexec [ -s %D/share/gnome/games/gnotski.36.scores ] || rm -f %D/share/gnome/games/gnotski.36.scores
+@unexec [ -s %D/share/gnome/games/gnotski.37.scores ] || rm -f %D/share/gnome/games/gnotski.37.scores
@unexec [ -s %D/share/gnome/games/gnotski.4.scores ] || rm -f %D/share/gnome/games/gnotski.4.scores
@unexec [ -s %D/share/gnome/games/gnotski.5.scores ] || rm -f %D/share/gnome/games/gnotski.5.scores
@unexec [ -s %D/share/gnome/games/gnotski.6.scores ] || rm -f %D/share/gnome/games/gnotski.6.scores
@unexec [ -s %D/share/gnome/games/gnotski.7.scores ] || rm -f %D/share/gnome/games/gnotski.7.scores
+@unexec [ -s %D/share/gnome/games/gnotski.8.scores ] || rm -f %D/share/gnome/games/gnotski.8.scores
+@unexec [ -s %D/share/gnome/games/gnotski.9.scores ] || rm -f %D/share/gnome/games/gnotski.9.scores
@unexec [ -s %D/share/gnome/games/gtali.scores ] || rm -f %D/share/gnome/games/gtali.scores
@unexec [ -s %D/share/gnome/games/mahjongg.bridges.scores ] || rm -f %D/share/gnome/games/mahjongg.bridges.scores
@unexec [ -s %D/share/gnome/games/mahjongg.cloud.scores ] || rm -f %D/share/gnome/games/mahjongg.cloud.scores
@@ -107,7 +124,9 @@ share/gnome/blackjack/Vegas_Strip.rules
@unexec [ -s %D/share/gnome/games/mahjongg.pyramid.scores ] || rm -f %D/share/gnome/games/mahjongg.pyramid.scores
@unexec [ -s %D/share/gnome/games/mahjongg.tictactoe.scores ] || rm -f %D/share/gnome/games/mahjongg.tictactoe.scores
@unexec [ -s %D/share/gnome/games/mahjongg.ziggurat.scores ] || rm -f %D/share/gnome/games/mahjongg.ziggurat.scores
-@unexec [ -s %D/share/gnome/games/same-gnome.scores ] || rm -f %D/share/gnome/games/same-gnome.scores
+@unexec [ -s %D/share/gnome/games/same-gnome.Large.scores ] || rm -f %D/share/gnome/games/same-gnome.Large.scores
+@unexec [ -s %D/share/gnome/games/same-gnome.Medium.scores ] || rm -f %D/share/gnome/games/same-gnome.Medium.scores
+@unexec [ -s %D/share/gnome/games/same-gnome.Small.scores ] || rm -f %D/share/gnome/games/same-gnome.Small.scores
share/gnome/gnect/white_ob.cn4
share/gnome/gnibbles/level001.gnl
share/gnome/gnibbles/level002.gnl
@@ -140,6 +159,9 @@ share/gnome/gnobots2/nightmare.cfg
share/gnome/gnobots2/robots2.cfg
share/gnome/gnobots2/robots2_easy.cfg
share/gnome/gnobots2/robots_with_safe_teleport.cfg
+share/gnome/gnome-games/mahjongg/maps/mahjongg.map
+share/gnome/gnome-games/same-gnome/themes/2.10/planets.png
+share/gnome/gnome-games/same-gnome/themes/2.10/stones.png
share/gnome/gnome-stones/atari.caves
share/gnome/gnome-stones/default.caves
share/gnome/gnome-stones/gnome-stonesrc
@@ -223,6 +245,83 @@ share/gnome/help/aisleriot/C/will_o_the_wisp.xml
share/gnome/help/aisleriot/C/yield.xml
share/gnome/help/aisleriot/C/yukon.xml
share/gnome/help/aisleriot/C/zebra.xml
+share/gnome/help/aisleriot/fr/agnes.xml
+share/gnome/help/aisleriot/fr/aisleriot.xml
+share/gnome/help/aisleriot/fr/auld_lang_syne.xml
+share/gnome/help/aisleriot/fr/bakers_dozen.xml
+share/gnome/help/aisleriot/fr/bakers_game.xml
+share/gnome/help/aisleriot/fr/beleaguered_castle.xml
+share/gnome/help/aisleriot/fr/block_ten.xml
+share/gnome/help/aisleriot/fr/bristol.xml
+share/gnome/help/aisleriot/fr/camelot.xml
+share/gnome/help/aisleriot/fr/canfield.xml
+share/gnome/help/aisleriot/fr/chessboard.xml
+share/gnome/help/aisleriot/fr/clock.xml
+share/gnome/help/aisleriot/fr/cover.xml
+share/gnome/help/aisleriot/fr/definitions.xml
+share/gnome/help/aisleriot/fr/diamond_mine.xml
+share/gnome/help/aisleriot/fr/doublets.xml
+share/gnome/help/aisleriot/fr/eagle-wing.xml
+share/gnome/help/aisleriot/fr/easthaven.xml
+share/gnome/help/aisleriot/fr/eight_off.xml
+share/gnome/help/aisleriot/fr/elevator.xml
+share/gnome/help/aisleriot/fr/escalator.xml
+share/gnome/help/aisleriot/fr/figures/camelot-goal.png
+share/gnome/help/aisleriot/fr/figures/clock-rules.png
+share/gnome/help/aisleriot/fr/first_law.xml
+share/gnome/help/aisleriot/fr/fortress.xml
+share/gnome/help/aisleriot/fr/fortunes.xml
+share/gnome/help/aisleriot/fr/fourteen.xml
+share/gnome/help/aisleriot/fr/freecell.xml
+share/gnome/help/aisleriot/fr/gay_gordons.xml
+share/gnome/help/aisleriot/fr/glenwood.xml
+share/gnome/help/aisleriot/fr/golf.xml
+share/gnome/help/aisleriot/fr/gypsy.xml
+share/gnome/help/aisleriot/fr/helsinki.xml
+share/gnome/help/aisleriot/fr/hopscotch.xml
+share/gnome/help/aisleriot/fr/isabel.xml
+share/gnome/help/aisleriot/fr/jamestown.xml
+share/gnome/help/aisleriot/fr/jumbo.xml
+share/gnome/help/aisleriot/fr/kansas.xml
+share/gnome/help/aisleriot/fr/king_albert.xml
+share/gnome/help/aisleriot/fr/klondike.xml
+share/gnome/help/aisleriot/fr/labyrinth.xml
+share/gnome/help/aisleriot/fr/lady_jane.xml
+share/gnome/help/aisleriot/fr/legal.xml
+share/gnome/help/aisleriot/fr/maze.xml
+share/gnome/help/aisleriot/fr/monte_carlo.xml
+share/gnome/help/aisleriot/fr/neighbor.xml
+share/gnome/help/aisleriot/fr/odessa.xml
+share/gnome/help/aisleriot/fr/osmosis.xml
+share/gnome/help/aisleriot/fr/peek.xml
+share/gnome/help/aisleriot/fr/pileon.xml
+share/gnome/help/aisleriot/fr/plait.xml
+share/gnome/help/aisleriot/fr/poker.xml
+share/gnome/help/aisleriot/fr/quatorze.xml
+share/gnome/help/aisleriot/fr/royal_east.xml
+share/gnome/help/aisleriot/fr/scorpion.xml
+share/gnome/help/aisleriot/fr/scuffle.xml
+share/gnome/help/aisleriot/fr/seahaven.xml
+share/gnome/help/aisleriot/fr/sir_tommy.xml
+share/gnome/help/aisleriot/fr/spider.xml
+share/gnome/help/aisleriot/fr/spider_one_suit.xml
+share/gnome/help/aisleriot/fr/spider_two_suit.xml
+share/gnome/help/aisleriot/fr/spiderette.xml
+share/gnome/help/aisleriot/fr/straight_up.xml
+share/gnome/help/aisleriot/fr/streets_and_alleys.xml
+share/gnome/help/aisleriot/fr/ten_across.xml
+share/gnome/help/aisleriot/fr/thieves.xml
+share/gnome/help/aisleriot/fr/thirteen.xml
+share/gnome/help/aisleriot/fr/thumb_and_pouch.xml
+share/gnome/help/aisleriot/fr/treize.xml
+share/gnome/help/aisleriot/fr/union_square.xml
+share/gnome/help/aisleriot/fr/valentine.xml
+share/gnome/help/aisleriot/fr/westhaven.xml
+share/gnome/help/aisleriot/fr/whitehead.xml
+share/gnome/help/aisleriot/fr/will_o_the_wisp.xml
+share/gnome/help/aisleriot/fr/yield.xml
+share/gnome/help/aisleriot/fr/yukon.xml
+share/gnome/help/aisleriot/fr/zebra.xml
share/gnome/help/blackjack/C/blackjack.xml
share/gnome/help/blackjack/C/figures/blackjack_start_window.png
share/gnome/help/blackjack/C/figures/blackjack_win_window.png
@@ -302,19 +401,17 @@ share/gnome/help/mahjongg/C/figures/mahjongg.png
share/gnome/help/mahjongg/C/figures/no-match.png
share/gnome/help/mahjongg/C/figures/no-move.png
share/gnome/help/mahjongg/C/figures/preferences.png
-share/gnome/help/mahjongg/C/figures/seed.png
share/gnome/help/mahjongg/C/figures/toolbar.png
share/gnome/help/mahjongg/C/legal.xml
share/gnome/help/mahjongg/C/mahjongg.xml
-share/gnome/help/same-gnome/C/figures/blink-sync.png
-share/gnome/help/same-gnome/C/figures/preferences.png
-share/gnome/help/same-gnome/C/figures/same-main-window.png
-share/gnome/help/same-gnome/C/figures/same-planets-fig.png
+share/gnome/help/same-gnome/C/figures/play.png
+share/gnome/help/same-gnome/C/figures/start-up.png
share/gnome/help/same-gnome/C/legal.xml
share/gnome/help/same-gnome/C/same-gnome.xml
share/gnome/mime-info/gnome-stones.keys
share/gnome/mime-info/gnome-stones.mime
share/gnome/omf/gnome-games/aisleriot-C.omf
+share/gnome/omf/gnome-games/aisleriot-fr.omf
share/gnome/omf/gnome-games/blackjack-C.omf
share/gnome/omf/gnome-games/gataxx-C.omf
share/gnome/omf/gnome-games/glines-C.omf
@@ -341,7 +438,7 @@ share/gnome/pixmaps/blackjack/chip-100.svg
share/gnome/pixmaps/blackjack/chip-25.svg
share/gnome/pixmaps/blackjack/chip-5.svg
share/gnome/pixmaps/cards/baize.png
-share/gnome/pixmaps/cards/slot.png
+share/gnome/pixmaps/cards/slot.svg
share/gnome/pixmaps/cards/slots/white-outline.svg
share/gnome/pixmaps/gataxx.png
share/gnome/pixmaps/glines.png
@@ -391,11 +488,11 @@ share/gnome/pixmaps/gnobots2/gnomes.png
share/gnome/pixmaps/gnobots2/robots.png
share/gnome/pixmaps/gnobots2/splat.png
share/gnome/pixmaps/gnobots2/yahoo.png
-share/gnome/pixmaps/gnome-games-common/cards/bonded.png
-share/gnome/pixmaps/gnome-games-common/cards/paris.svg
share/gnome/pixmaps/gnome-aisleriot.png
share/gnome/pixmaps/gnome-blackjack.png
share/gnome/pixmaps/gnome-cardgame.png
+share/gnome/pixmaps/gnome-games-common/cards/bonded.png
+share/gnome/pixmaps/gnome-games-common/cards/paris.svg
share/gnome/pixmaps/gnome-gnobots2.png
share/gnome/pixmaps/gnome-gnomine.png
share/gnome/pixmaps/gnome-gnotravex.png
@@ -434,7 +531,7 @@ share/gnome/pixmaps/gnomine/flag-question.svg
share/gnome/pixmaps/gnomine/flag.svg
share/gnome/pixmaps/gnomine/mine.svg
share/gnome/pixmaps/gnotski-icon.png
-share/gnome/pixmaps/gnotski.png
+share/gnome/pixmaps/gnotski.svg
share/gnome/pixmaps/gtali/gnome-dice-1.svg
share/gnome/pixmaps/gtali/gnome-dice-2.svg
share/gnome/pixmaps/gtali/gnome-dice-3.svg
@@ -448,8 +545,6 @@ share/gnome/pixmaps/iagno/woodtrim.png
share/gnome/pixmaps/mahjongg/postmodern.svg
share/gnome/pixmaps/mahjongg/smooth.png
share/gnome/pixmaps/rteleport.png
-share/gnome/pixmaps/same-gnome/planets.png
-share/gnome/pixmaps/same-gnome/stones.png
share/gnome/pixmaps/teleport.png
share/gnome/sol-games/agnes.scm
share/gnome/sol-games/auld_lang_syne.scm
@@ -616,7 +711,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
@dirrm share/gnome/sounds/gnibbles
@dirrm share/gnome/sol-games/glade
@dirrm share/gnome/sol-games
-@dirrm share/gnome/pixmaps/same-gnome
@dirrm share/gnome/pixmaps/mahjongg
@dirrm share/gnome/pixmaps/iagno
@dirrm share/gnome/pixmaps/gtali
@@ -681,10 +775,18 @@ share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
@dirrm share/gnome/help/blackjack/C/figures
@dirrm share/gnome/help/blackjack/C
@dirrm share/gnome/help/blackjack
+@dirrm share/gnome/help/aisleriot/fr/figures
+@dirrm share/gnome/help/aisleriot/fr
@dirrm share/gnome/help/aisleriot/C/figures
@dirrm share/gnome/help/aisleriot/C
@dirrm share/gnome/help/aisleriot
@dirrm share/gnome/gnome-stones
+@dirrm share/gnome/gnome-games/same-gnome/themes/2.10
+@dirrm share/gnome/gnome-games/same-gnome/themes
+@dirrm share/gnome/gnome-games/same-gnome
+@dirrm share/gnome/gnome-games/mahjongg/maps
+@dirrm share/gnome/gnome-games/mahjongg
+@dirrm share/gnome/gnome-games
@dirrm share/gnome/gnobots2
@dirrm share/gnome/gnibbles
@dirrm share/gnome/gnect