aboutsummaryrefslogtreecommitdiffstats
path: root/games/goonies
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-04 09:47:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-04 09:47:03 +0800
commit172f8d9550ec61cd132310ff56cdf3487829cd5d (patch)
tree83643c37abd39370e4ec2b1add60937c02a6aa8c /games/goonies
parent33a7b6b42d0b858661b326355bf86d901afddcb8 (diff)
downloadfreebsd-ports-gnome-172f8d9550ec61cd132310ff56cdf3487829cd5d.tar.gz
freebsd-ports-gnome-172f8d9550ec61cd132310ff56cdf3487829cd5d.tar.zst
freebsd-ports-gnome-172f8d9550ec61cd132310ff56cdf3487829cd5d.zip
- Support staging
- Convert USE_GMAKE to USES
Diffstat (limited to 'games/goonies')
-rw-r--r--games/goonies/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/games/goonies/Makefile b/games/goonies/Makefile
index b1e0d47d9436..f202701ffea4 100644
--- a/games/goonies/Makefile
+++ b/games/goonies/Makefile
@@ -13,7 +13,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Remake of the 8 bit classic game 'The Goonies'
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl mixer image
USE_GL= yes
@@ -23,11 +23,9 @@ MAKE_ENV= DATADIR="${DATADIR}"
PLIST_FILES= bin/${PORTNAME}
-DATADIRS= sound graphics maps
PORTDOCS= *
PORTDATA= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
@@ -43,14 +41,13 @@ post-patch:
${WRKSRC}/src/TheGoonies.cpp
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/goonies ${PREFIX}/bin/
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} 'sound graphics maps' ${DATADIR}/
-.endif
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/goonies ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ 'sound graphics maps' ${STAGEDIR}${DATADIR}/
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>