aboutsummaryrefslogtreecommitdiffstats
path: root/games/gottet
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-02-04 21:57:54 +0800
committernemysis <nemysis@FreeBSD.org>2014-02-04 21:57:54 +0800
commit9037e5222e168775e76bee29a63648aa9afa59c4 (patch)
tree5707eb517050c0cb883dd4cd4925c5589456cd7d /games/gottet
parent7739b40ddd4e5c709ec3382bd6e3d6c5befa25fd (diff)
downloadfreebsd-ports-gnome-9037e5222e168775e76bee29a63648aa9afa59c4.tar.gz
freebsd-ports-gnome-9037e5222e168775e76bee29a63648aa9afa59c4.tar.zst
freebsd-ports-gnome-9037e5222e168775e76bee29a63648aa9afa59c4.zip
- Add NLS Option and REINPLACE
- Add OPTIONS_SUB - Strip executable - Recreate pkg-plist with make makeplist
Diffstat (limited to 'games/gottet')
-rw-r--r--games/gottet/Makefile13
-rw-r--r--games/gottet/pkg-plist12
2 files changed, 18 insertions, 7 deletions
diff --git a/games/gottet/Makefile b/games/gottet/Makefile
index e89f333d032d..4395e952f768 100644
--- a/games/gottet/Makefile
+++ b/games/gottet/Makefile
@@ -20,9 +20,20 @@ INSTALLS_ICONS= yes
PORTDOCS= CREDITS ChangeLog
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -i '' '/qm.files/,/qm.path/s/^/#/' \
+ ${WRKSRC}/${PORTNAME}.pro
+.endif
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
diff --git a/games/gottet/pkg-plist b/games/gottet/pkg-plist
index 19019a1d5bd2..5f757ad63a61 100644
--- a/games/gottet/pkg-plist
+++ b/games/gottet/pkg-plist
@@ -1,9 +1,9 @@
bin/gottet
share/applications/gottet.desktop
-%%DATADIR%%/translations/gottet_en.qm
-%%DATADIR%%/translations/gottet_fr.qm
-%%DATADIR%%/translations/gottet_he.qm
-%%DATADIR%%/translations/gottet_ro.qm
+%%NLS%%%%DATADIR%%/translations/gottet_en.qm
+%%NLS%%%%DATADIR%%/translations/gottet_fr.qm
+%%NLS%%%%DATADIR%%/translations/gottet_he.qm
+%%NLS%%%%DATADIR%%/translations/gottet_ro.qm
share/icons/hicolor/128x128/apps/gottet.png
share/icons/hicolor/16x16/apps/gottet.png
share/icons/hicolor/22x22/apps/gottet.png
@@ -15,5 +15,5 @@ share/icons/hicolor/64x64/apps/gottet.png
share/icons/hicolor/scalable/apps/gottet.svg
share/pixmaps/gottet.png
share/pixmaps/gottet.xpm
-@dirrm %%DATADIR%%/translations
-@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry %%DATADIR%%/translations
+%%NLS%%@dirrmtry %%DATADIR%%