aboutsummaryrefslogtreecommitdiffstats
path: root/games/gracer
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /games/gracer
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'games/gracer')
-rw-r--r--games/gracer/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index 8c030e658637..c226fcaef7d9 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -9,28 +9,27 @@ PORTNAME= gracer
PORTVERSION= 0.1.5
PORTREVISION= 4
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= nox@FreeBSD.org
COMMENT= A 3D motor sport simulator
-BUILD_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
+BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- tcl82.1:${PORTSDIR}/lang/tcl82 \
- glut.4:${PORTSDIR}/graphics/libglut
+ tcl82.1:${PORTSDIR}/lang/tcl82
+USE_GL= glut
USE_PERL5_BUILD=yes
USE_AUTOTOOLS= autoconf:213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
-I${LOCALBASE}/include/tcl8.2 \
- -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+ -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib"
USE_GMAKE= yes
# for plib (sound):
-CONFIGURE_ARGS+= --with-plib=${X11BASE}/plib
+CONFIGURE_ARGS+= --with-plib=${LOCALBASE}/plib
MAN6= gracer.6