aboutsummaryrefslogtreecommitdiffstats
path: root/games/gti/Makefile
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2013-05-14 21:31:42 +0800
committertota <tota@FreeBSD.org>2013-05-14 21:31:42 +0800
commitdb7d37c58a97b8fa1a43be3f68f291131dafc20a (patch)
tree93e9968bc6c134c8bbb8c098a11a4b364e221310 /games/gti/Makefile
parentaafbf0af2056f5c88919652dbca31cfec64fce1b (diff)
downloadfreebsd-ports-gnome-db7d37c58a97b8fa1a43be3f68f291131dafc20a.tar.gz
freebsd-ports-gnome-db7d37c58a97b8fa1a43be3f68f291131dafc20a.tar.zst
freebsd-ports-gnome-db7d37c58a97b8fa1a43be3f68f291131dafc20a.zip
- Update to 1.1.0
* Add a man page * Expose the speed of the animation - Trim Makefile header - Replace tab with a space after WWW: in pkg-descr
Diffstat (limited to 'games/gti/Makefile')
-rw-r--r--games/gti/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/games/gti/Makefile b/games/gti/Makefile
index 5e2eea7f94dd..68765f1259cc 100644
--- a/games/gti/Makefile
+++ b/games/gti/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: gti
-# Date created: 2012-08-16
-# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
-#
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gti
-PORTVERSION= 1.0.4
+PORTVERSION= 1.1.0
CATEGORIES= games
MAINTAINER= tota@FreeBSD.org
@@ -15,16 +11,26 @@ COMMENT= Just a silly git launcher, basically. Inspired by sl
USE_GITHUB= yes
GH_ACCOUNT= rwos
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= e16ca0b
+GH_COMMIT= 5afb520
-ALL_TARGET= ${PORTNAME}
+MAN6= ${PORTNAME}.6
PLIST_FILES= bin/${PORTNAME}
+GTI_SPEED?= 50
+CFLAGS+= -DGTI_SPEED=${GTI_SPEED}
+
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} " You can change the speed of the car at compile time."
+ @${ECHO_MSG} " For example: \"make GTI_SPEED=100\" # default is 50"
+ @${ECHO_MSG}
+
do-build:
@${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MANPREFIX}/man/man6
.include <bsd.port.mk>