aboutsummaryrefslogtreecommitdiffstats
path: root/games/gweled
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-12-02 04:52:14 +0800
committermarcus <marcus@FreeBSD.org>2004-12-02 04:52:14 +0800
commit4ddc4816bcba9d26fbde3a8d460abfaf4f7b3a96 (patch)
treebdfb70a385bd4b84e1fcbbddf8fdba50714d140f /games/gweled
parent741639098352531c0b3cddfca79f8aff7cba9329 (diff)
downloadfreebsd-ports-gnome-4ddc4816bcba9d26fbde3a8d460abfaf4f7b3a96.tar.gz
freebsd-ports-gnome-4ddc4816bcba9d26fbde3a8d460abfaf4f7b3a96.tar.zst
freebsd-ports-gnome-4ddc4816bcba9d26fbde3a8d460abfaf4f7b3a96.zip
Update to 0.6.
PR: 74598 Submitted by: Radek Kozlowski <radek@raadradd.com>
Diffstat (limited to 'games/gweled')
-rw-r--r--games/gweled/Makefile10
-rw-r--r--games/gweled/distinfo4
-rw-r--r--games/gweled/pkg-install4
3 files changed, 12 insertions, 6 deletions
diff --git a/games/gweled/Makefile b/games/gweled/Makefile
index d3b141c718f9..07c4aadef3aa 100644
--- a/games/gweled/Makefile
+++ b/games/gweled/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gweled
-PORTVERSION= 0.5
-PORTREVISION= 1
+PORTVERSION= 0.6
CATEGORIES= games gnome
MASTER_SITES= http://sebdelestaing.free.fr/gweled/Release/
@@ -17,6 +16,13 @@ COMMENT= GNOME version of the game called "Bejeweled" or "Diamond Mine"
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui librsvg2
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|/var/games|${PREFIX}/share/gnome/games|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$${MKDIRPROG-mkdir}|mkdir -p|' \
+ ${WRKSRC}/install-sh
+
.include <bsd.port.mk>
diff --git a/games/gweled/distinfo b/games/gweled/distinfo
index b444090ceeac..78bf50cde671 100644
--- a/games/gweled/distinfo
+++ b/games/gweled/distinfo
@@ -1,2 +1,2 @@
-MD5 (gweled-0.5.tar.gz) = 238f5ef66317bb24c3d4018a7d1e9ec3
-SIZE (gweled-0.5.tar.gz) = 163122
+MD5 (gweled-0.6.tar.gz) = 40b4eaa8e1aca93cf6bc9d91a3c2c048
+SIZE (gweled-0.6.tar.gz) = 168308
diff --git a/games/gweled/pkg-install b/games/gweled/pkg-install
index 1f83654a3934..04fcca9ba5f7 100644
--- a/games/gweled/pkg-install
+++ b/games/gweled/pkg-install
@@ -2,12 +2,12 @@
if [ "$2" = "POST-INSTALL" ]; then
mkdir -p ${PKG_PREFIX}/share/gnome/games
- SCORES="gweled.easy.scores"
+ SCORES="gweled.easy.scores gweled.timed.scores"
for i in ${SCORES}; do
if [ ! -f ${PKG_PREFIX}/share/gnome/games/${i} ]; then
touch -f ${PKG_PREFIX}/share/gnome/games/${i}
chown games:games ${PKG_PREFIX}/share/gnome/games/${i}
- chmod 664 ${PKG_PREFIX}/share/gnome/games/${i}
+ chmod 0664 ${PKG_PREFIX}/share/gnome/games/${i}
fi
done
fi