aboutsummaryrefslogtreecommitdiffstats
path: root/games/heretic/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-12-31 18:59:27 +0800
committeroliver <oliver@FreeBSD.org>2006-12-31 18:59:27 +0800
commit72cf86a675fecf4a9ddabef39687f478e3d2695b (patch)
tree83035985fee5ec611db5e0f60d770f197864a8b1 /games/heretic/Makefile
parent21336a8df52a2b9262f0b26495ea768783503ead (diff)
downloadfreebsd-ports-gnome-72cf86a675fecf4a9ddabef39687f478e3d2695b.tar.gz
freebsd-ports-gnome-72cf86a675fecf4a9ddabef39687f478e3d2695b.tar.zst
freebsd-ports-gnome-72cf86a675fecf4a9ddabef39687f478e3d2695b.zip
fix for amd64 (compiled, but segfaulted)
fix build with FASTX11 OPTIONify bump PORTREVISION
Diffstat (limited to 'games/heretic/Makefile')
-rw-r--r--games/heretic/Makefile39
1 files changed, 21 insertions, 18 deletions
diff --git a/games/heretic/Makefile b/games/heretic/Makefile
index 352b557a646d..a91b6f871ca4 100644
--- a/games/heretic/Makefile
+++ b/games/heretic/Makefile
@@ -7,15 +7,11 @@
PORTNAME= heretic
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://heretic.linuxgames.com/heretic/src/:source \
http://heretic.linuxgames.com/wad/:wad
DISTNAME= gl${PORTNAME}-${PORTVERSION}
-.if !defined(WITHOUT_WAD)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:source heretic_share.wad.gz:wad
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-.endif
MAINTAINER= oliver@FreeBSD.org
COMMENT= Unix source-port of the famous Heretic game by id Software
@@ -24,8 +20,22 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+OPTIONS= X11 "Use X11" on \
+ FASTX11 "Use FastX11" off \
+ SDL "Use SDL" off \
+ WAD "With shareware WAD" on
+
+.include <bsd.port.pre.mk>
+
+.if (defined(WITH_X11) && (defined(WITH_FASTX11) || defined(WITH_SDL))) || \
+ (defined(WITH_FASTX11) && (defined(WITH_X11) || defined(WITH_SDL)))
+IGNORE= you must only define X11, xor FASTX11, xor SDL
+.endif
+
+.if defined(WITH_X11)
ALL_TARGET= x11
BINARY= xheretic
+.endif
.if defined(WITH_FASTX11)
ALL_TARGET= fastx11
@@ -39,21 +49,14 @@ BINARY= sdlheretic
CFLAGS+= `${SDL_CONFIG} --cflags`
.endif
-.if defined(WITHOUT_WAD)
-PLIST_SUB= WAD:="@comment "
-.else
+.if defined(WITH_WAD)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:source heretic_share.wad.gz:wad
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
PLIST_SUB= WAD:=""
+.else
+PLIST_SUB= WAD:="@comment "
.endif
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_FASTX11=yes Use FastX11 support"
- @${ECHO} " WITH_SDL=yes Use SDL."
- @${ECHO} " WITHOUT_WAD=yes Don't install the wad file."
- @${ECHO} ""
-
post-extract:
.if !defined(WITHOUT_WAD)
@${GZIP_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/heretic_share.wad.gz \
@@ -73,4 +76,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/heretic
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>