aboutsummaryrefslogtreecommitdiffstats
path: root/games/heretic/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-08-30 12:55:45 +0800
committerlioux <lioux@FreeBSD.org>2002-08-30 12:55:45 +0800
commit049c411c025c866f2229e49d4bba48e9613116f9 (patch)
tree6aed0862d98ce836ab584b1c671bd467d8b48b88 /games/heretic/Makefile
parentf760bd557425f7bd6bd9fa868e899a7e4d6f9932 (diff)
downloadfreebsd-ports-gnome-049c411c025c866f2229e49d4bba48e9613116f9.tar.gz
freebsd-ports-gnome-049c411c025c866f2229e49d4bba48e9613116f9.tar.zst
freebsd-ports-gnome-049c411c025c866f2229e49d4bba48e9613116f9.zip
o Depend on sdl12 port instead of sdl10 one
o This fixes an outstanding full screen mode bug o PORTREVISION bump since port builded but did not work PR: 41604 Submitted by: Edwin Groothuis <edwin@mavetju.org> Approved by: maintainer
Diffstat (limited to 'games/heretic/Makefile')
-rw-r--r--games/heretic/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/heretic/Makefile b/games/heretic/Makefile
index 0dee74e51641..e71b7595db2f 100644
--- a/games/heretic/Makefile
+++ b/games/heretic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= heretic
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://heretic.linuxgames.com/heretic/src/ \
http://heretic.linuxgames.com/wad/
@@ -34,7 +35,7 @@ BINARY= xaheretic
ALL_TARGET= sdl
BINARY= sdlheretic
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl10
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
MAKE_ENV+= SDL_CONFIG="${SDL_CONFIG}"
CFLAGS+= `${SDL_CONFIG} --cflags`
.endif