aboutsummaryrefslogtreecommitdiffstats
path: root/games/heroes
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-09 21:19:24 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-09 21:19:24 +0800
commit9aa9cb74ca3f3ffd19111ebb5b18dd7ebb4c7c62 (patch)
tree0a2f31cc38f5e5159bbe9f793f2d08699b701718 /games/heroes
parent64c6d59d4067f9ac7f1602f9cdbd7e2aabcef6a8 (diff)
downloadfreebsd-ports-gnome-9aa9cb74ca3f3ffd19111ebb5b18dd7ebb4c7c62.tar.gz
freebsd-ports-gnome-9aa9cb74ca3f3ffd19111ebb5b18dd7ebb4c7c62.tar.zst
freebsd-ports-gnome-9aa9cb74ca3f3ffd19111ebb5b18dd7ebb4c7c62.zip
- Fix MASTER_SITES
- Add LICENSE - Add MAKE_JOBS_SAFE PR: 159448 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'games/heroes')
-rw-r--r--games/heroes/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index da43dda0a5c4..9653339a2ad2 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -9,17 +9,21 @@ PORTNAME= heroes
PORTVERSION= 0.21
PORTREVISION= 13
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= SF \
+ SF/${PORTNAME}/${PORTNAME}-data/${DATAVERSION}:data \
+ SF/${PORTNAME}/${PORTNAME}-sound-effects/${SOUNDVERSION}:sound \
+ SF/${PORTNAME}/${PORTNAME}-sound-tracks/${MUSICVERSION}:music
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- ${DATADISTNAME}${EXTRACT_SUFX} \
- ${SOUNDISTNAME}${EXTRACT_SUFX} \
- ${MUSICDISTNAME}${EXTRACT_SUFX}
-#PATCH_SITES= ftp://heroes.sourceforge.net/pub/heroes/patches/
-#PATCHFILES= heroes-0.7-errata.patch
+ ${DATADISTNAME}${EXTRACT_SUFX}:data \
+ ${SOUNDISTNAME}${EXTRACT_SUFX}:sound \
+ ${MUSICDISTNAME}${EXTRACT_SUFX}:music
MAINTAINER= ports@FreeBSD.org
COMMENT= A game of yore similar to the "Tron" and "Nibbles"
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
DATAVERSION= 1.5
SOUNDVERSION= 1.0
MUSICVERSION= 1.0
@@ -35,9 +39,10 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE} --without-gii --without-ggi
+MAKE_JOBS_SAFE= yes
.if defined(WITH_OPTIMIZED_CFLAGS)
CONFIGURE_ARGS+=--enable-optimizations