aboutsummaryrefslogtreecommitdiffstats
path: root/games/heroes
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-08 08:15:34 +0800
committermarino <marino@FreeBSD.org>2013-10-08 08:15:34 +0800
commitad2e6d9cbccd260dd87a0b628896acf13b94a652 (patch)
tree39be84d6997d264d9ca2a8ab4f521d044421e824 /games/heroes
parent2cdc7a8011d68e815fb70ceef695ab41675a6ca2 (diff)
downloadfreebsd-ports-gnome-ad2e6d9cbccd260dd87a0b628896acf13b94a652.tar.gz
freebsd-ports-gnome-ad2e6d9cbccd260dd87a0b628896acf13b94a652.tar.zst
freebsd-ports-gnome-ad2e6d9cbccd260dd87a0b628896acf13b94a652.zip
Explicitly link libraries on 10 unmaintained ports
The following ports will not build with a binutils 2.22+ linker built with standard options. This has been obvious with DPorts, but difficult to see on FreeBSD. However, setting the ports compiler as a recent gcc (e.g lang/gcc48) is an excellent way to detect the unspecified but needed libraries as these recent GCC compilers use the latest binutils linkers. These patches were tested on FreeBSD 8.4 and DragonFly 3.5
Diffstat (limited to 'games/heroes')
-rw-r--r--games/heroes/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 30d10011046e..9a0029491ca1 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -47,7 +47,7 @@ MAN6= heroes.6 heroeslvl.6
INFO= heroes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib -lsmpeg ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib -lsmpeg -lm ${PTHREAD_LIBS}
NO_STAGE= yes
pre-everything::