aboutsummaryrefslogtreecommitdiffstats
path: root/games/hexalate
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-04-10 05:54:55 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-04-10 05:54:55 +0800
commitb0653a9ab9e341c08d17668e58652ede4c5bbb02 (patch)
tree19af1384c999d20bae47f82ba2c1ad7e54f19542 /games/hexalate
parent9ad273459839cc335cf8498c89a94d6cb16ebe51 (diff)
downloadfreebsd-ports-gnome-b0653a9ab9e341c08d17668e58652ede4c5bbb02.tar.gz
freebsd-ports-gnome-b0653a9ab9e341c08d17668e58652ede4c5bbb02.tar.zst
freebsd-ports-gnome-b0653a9ab9e341c08d17668e58652ede4c5bbb02.zip
Hexalate is a color matching game. The goal of the game is to rotate
and position the circles so that each touching line matches in color. You rotate circles by right clicking, and you move circles by dragging them. The game stores the positions and rotations of the circles across runs. WWW: http://gottcode.org/hexalate/
Diffstat (limited to 'games/hexalate')
-rw-r--r--games/hexalate/Makefile34
-rw-r--r--games/hexalate/distinfo3
-rw-r--r--games/hexalate/pkg-descr7
-rw-r--r--games/hexalate/pkg-plist8
4 files changed, 52 insertions, 0 deletions
diff --git a/games/hexalate/Makefile b/games/hexalate/Makefile
new file mode 100644
index 000000000000..36c6ad7581ac
--- /dev/null
+++ b/games/hexalate/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: hexalate
+# Date created: 09 Apr 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hexalate
+PORTVERSION= 1.0.0
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/${PORTNAME}/ \
+ http://mirror.amdmi3.ru/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= A color matching game
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui svg moc_build qmake_build rcc_build
+WANT_GNOME= yes
+INSTALLS_ICONS= yes
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ PREFIX=${PREFIX} -spec ${QMAKESPEC} ${PORTNAME}.pro
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/hexalate/distinfo b/games/hexalate/distinfo
new file mode 100644
index 000000000000..8168b9b024fa
--- /dev/null
+++ b/games/hexalate/distinfo
@@ -0,0 +1,3 @@
+MD5 (hexalate-1.0.0-src.tar.bz2) = c4b8e5dbca4520843abc502acae3dbae
+SHA256 (hexalate-1.0.0-src.tar.bz2) = c3e24388eb6a9f127884853756cf148ac5806a87083129893f7cf3c2ccb9846a
+SIZE (hexalate-1.0.0-src.tar.bz2) = 48749
diff --git a/games/hexalate/pkg-descr b/games/hexalate/pkg-descr
new file mode 100644
index 000000000000..2b7339e57225
--- /dev/null
+++ b/games/hexalate/pkg-descr
@@ -0,0 +1,7 @@
+Hexalate is a color matching game. The goal of the game is to rotate
+and position the circles so that each touching line matches in
+color. You rotate circles by right clicking, and you move circles
+by dragging them. The game stores the positions and rotations of
+the circles across runs.
+
+WWW: http://gottcode.org/hexalate/
diff --git a/games/hexalate/pkg-plist b/games/hexalate/pkg-plist
new file mode 100644
index 000000000000..9b5909a5b9d9
--- /dev/null
+++ b/games/hexalate/pkg-plist
@@ -0,0 +1,8 @@
+bin/hexalate
+share/applications/hexalate.desktop
+share/icons/hicolor/48x48/apps/hexalate.png
+@dirrm share/icons/hicolor/48x48/apps
+@dirrm share/icons/hicolor/48x48
+@dirrm share/icons/hicolor
+@dirrm share/icons
+@dirrmtry share/applications