aboutsummaryrefslogtreecommitdiffstats
path: root/games/icbm3d/Makefile
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-12-24 16:20:21 +0800
committernemysis <nemysis@FreeBSD.org>2013-12-24 16:20:21 +0800
commit73ec8f535246323718c83fe7c750b948c25572d0 (patch)
tree45b19b2a73385e51019907604bf2190ff916cc2b /games/icbm3d/Makefile
parent07901352193435511a38c78ceccf0feab22fdd04 (diff)
downloadfreebsd-ports-gnome-73ec8f535246323718c83fe7c750b948c25572d0.tar.gz
freebsd-ports-gnome-73ec8f535246323718c83fe7c750b948c25572d0.tar.zst
freebsd-ports-gnome-73ec8f535246323718c83fe7c750b948c25572d0.zip
- Bump PORTREVISION
- Change master sites and icon - Support STAGEDIR - Add DOCS Option - Add Desktop entry file - Simplify Makefile - Add patches, fix bad C++ code Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'games/icbm3d/Makefile')
-rw-r--r--games/icbm3d/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/games/icbm3d/Makefile b/games/icbm3d/Makefile
index 9759b99d1377..e58773b68e09 100644
--- a/games/icbm3d/Makefile
+++ b/games/icbm3d/Makefile
@@ -3,43 +3,40 @@
PORTNAME= icbm3d
PORTVERSION= 0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/icbm3d/ \
ftp://ftp.billsgames.com/unix/x/icbm3d/ \
- http://www.newbreedsoftware.com/images/prodicons/:icons
+ SF/nemysisfreebsdp/games/${PORTNAME}/:icons
DISTFILES= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}.gif:icons
+ ${PORTNAME}.png:icons
EXTRACT_ONLY= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Inter-Continental Ballistic Missiles, 3D
-WRKSRC= ${WRKDIR}/icbm3d
+WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= x11
MAKEFILE= makefile
ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.gif
+ share/pixmaps/${PORTNAME}.png
PORTDOCS= README.txt
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
-do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+DESKTOP_ENTRIES="ICBM3D" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
-# Pixmaps
- ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.gif ${PREFIX}/share/pixmaps/
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-# Documentation
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>