aboutsummaryrefslogtreecommitdiffstats
path: root/games/imaze/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-06-09 23:33:28 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-06-09 23:33:28 +0800
commitc829dec847f90199d0d7d44713c95d02395e6d35 (patch)
tree9e45cea72b2ff3ed81fca7dceb4f892eb1f7b13d /games/imaze/Makefile
parentb246222bf190a67c421dcb4a82dc5bd01a13f149 (diff)
downloadfreebsd-ports-gnome-c829dec847f90199d0d7d44713c95d02395e6d35.tar.gz
freebsd-ports-gnome-c829dec847f90199d0d7d44713c95d02395e6d35.tar.zst
freebsd-ports-gnome-c829dec847f90199d0d7d44713c95d02395e6d35.zip
Convert most of remaining ports that depend on xorg-libraries to
modular xorg. - supply corresponding USE_XORG for all imake-using ports that need it - USE_IMAKE no longer implies USE_XLIB in absence of USE_XORG - retire USE_X_PREFIX which is not really used anywhere after the above change - a few minor nits like whitespace and SF macro Tested by: 2 tinderbox runs by pav Approved by: portmgr (pav)
Diffstat (limited to 'games/imaze/Makefile')
-rw-r--r--games/imaze/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/imaze/Makefile b/games/imaze/Makefile
index ce62776583e8..ac3ae46398fc 100644
--- a/games/imaze/Makefile
+++ b/games/imaze/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imaze
PORTVERSION= 1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://home.tu-clausthal.de/student/iMaze/files/
PKGNAMESUFFIX= -${TOOLKIT}
@@ -20,9 +20,11 @@ USE_MOTIF= yes
TOOLKIT= motif
.elif defined(WITH_ATHENA)
TOOLKIT= athena
+USE_XORG+= xaw
.else
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
TOOLKIT= xview
+USE_XORG+= xaw
.endif
HAS_CONFIGURE= yes
@@ -32,6 +34,7 @@ BUILD_WRKSRC= ${WRKSRC}/source
MAKE_ENV= SOUNDDIR=${SOUNDDIR}
MAN6= genlab.6 imaze.6 imazesrv.6 imazestat.6 ninja.6 xlabed.6
MANCOMPRESSED= no
+USE_XORG+= x11 xt
.if defined(WITHOUT_AUDIO)
CONFIGURE_ARGS+=noaudio