aboutsummaryrefslogtreecommitdiffstats
path: root/games/inform/files
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-06-28 23:16:08 +0800
committermph <mph@FreeBSD.org>1998-06-28 23:16:08 +0800
commit331a10a37800aa6a84254b727825e1a680bb67b1 (patch)
tree101c2eb141c5136d394928d12a7594adebbcf458 /games/inform/files
parent7d3188e6a37c1e197aca4130354119341f9c76e7 (diff)
downloadfreebsd-ports-gnome-331a10a37800aa6a84254b727825e1a680bb67b1.tar.gz
freebsd-ports-gnome-331a10a37800aa6a84254b727825e1a680bb67b1.tar.zst
freebsd-ports-gnome-331a10a37800aa6a84254b727825e1a680bb67b1.zip
Import of Inform 6.15 and version 6/7 of its library. Inform is
a compiler for producing adventure games. The output is compatible with Infocom interpreters, which offers cross-platform compatibility and a choice of interface.
Diffstat (limited to 'games/inform/files')
-rw-r--r--games/inform/files/Makefile.inform15
-rw-r--r--games/inform/files/patch-aa11
2 files changed, 26 insertions, 0 deletions
diff --git a/games/inform/files/Makefile.inform b/games/inform/files/Makefile.inform
new file mode 100644
index 000000000000..856d96511ae2
--- /dev/null
+++ b/games/inform/files/Makefile.inform
@@ -0,0 +1,15 @@
+# $Id$
+
+OBJS= arrays.o asm.o bpatch.o chars.o directs.o errors.o expressc.o \
+ expressp.o files.o inform.o lexer.o linker.o memory.o objects.o \
+ states.o symbols.o syntax.o tables.o text.o veneer.o verbs.o
+
+CFLAGS+= -DInclude_Directory=\"${PREFIX}/share/inform\"
+
+all: inform
+
+inform: $(OBJS)
+ $(CC) $(CFLAGS) -o ${.TARGET} $(OBJS)
+
+install: inform
+ ${BSD_INSTALL_PROGRAM} inform ${PREFIX}/bin
diff --git a/games/inform/files/patch-aa b/games/inform/files/patch-aa
new file mode 100644
index 000000000000..37f11f4dff84
--- /dev/null
+++ b/games/inform/files/patch-aa
@@ -0,0 +1,11 @@
+--- header.h.orig Sun Jun 28 00:54:48 1998
++++ header.h Sun Jun 28 00:58:25 1998
+@@ -66,7 +66,7 @@
+ /* out a block of definitions like those below.) */
+ /* ------------------------------------------------------------------------- */
+
+-#define ARCHIMEDES
++#define UNIX
+
+ /* ------------------------------------------------------------------------- */
+ /* The first task is to include the ANSI header files, and typedef */