aboutsummaryrefslogtreecommitdiffstats
path: root/games/ioquake3
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-06-12 06:59:50 +0800
committeralepulver <alepulver@FreeBSD.org>2006-06-12 06:59:50 +0800
commite24888c03b09ec9d0e1733698b0a1c7b253f9cc7 (patch)
tree3f82b725e16c91fdfdaa05af147a0237bd600006 /games/ioquake3
parent288b6cbd63273a951de40cb09fa1ba3bd612eaa3 (diff)
downloadfreebsd-ports-gnome-e24888c03b09ec9d0e1733698b0a1c7b253f9cc7.tar.gz
freebsd-ports-gnome-e24888c03b09ec9d0e1733698b0a1c7b253f9cc7.tar.zst
freebsd-ports-gnome-e24888c03b09ec9d0e1733698b0a1c7b253f9cc7.zip
- Update to version 1.33 (SVN rev 797).
- Add pkg-message about how to fix SDL sound problems.
Diffstat (limited to 'games/ioquake3')
-rw-r--r--games/ioquake3/Makefile8
-rw-r--r--games/ioquake3/distinfo6
-rw-r--r--games/ioquake3/files/patch-Makefile45
-rw-r--r--games/ioquake3/files/patch-code__botlib__be_interface.c2
-rw-r--r--games/ioquake3/files/patch-code__qcommon__common.c2
-rw-r--r--games/ioquake3/files/patch-code__qcommon__q_platform.h2
-rw-r--r--games/ioquake3/files/patch-code__unix__linux_glimp.c2
-rw-r--r--games/ioquake3/files/patch-code__unix__unix_main.c2
-rw-r--r--games/ioquake3/pkg-message10
9 files changed, 47 insertions, 32 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index a89be3f852a7..7bd59b9a226e 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ioquake3
-PORTVERSION= 1.33
+PORTVERSION= 1.33.${SVN_REV}
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= alepulver
@@ -35,7 +35,7 @@ MAKE_ENV+= DEFAULT_BASEDIR="${Q3DIR}" LIBDIR="${LIBDIR}" \
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
LIBDIR= ${PREFIX}/lib/${PORTNAME}
-SVN_REV= 777
+SVN_REV= 797
VM_ARCHS= amd64 i386 powerpc
.include <bsd.port.pre.mk>
@@ -139,11 +139,9 @@ do-install:
.endif
post-install:
-.if defined(WITH_SDL_AUDIO) || defined(WITH_OPENAL)
@${ECHO_CMD}
- @${ECHO_CMD} "WARNING: if you have sound problems try recompiling without SDL_AUDIO and OPENAL options." | ${FMT}
+ @${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.endif
maint-gen-distfile:
@if [ -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
diff --git a/games/ioquake3/distinfo b/games/ioquake3/distinfo
index 17bc6407080a..8b439d85f147 100644
--- a/games/ioquake3/distinfo
+++ b/games/ioquake3/distinfo
@@ -1,3 +1,3 @@
-MD5 (ioquake3-1.33.tar.bz2) = 0eaf6eb252e6b56d1195faf2d898c533
-SHA256 (ioquake3-1.33.tar.bz2) = 9e9b7f4d7b39eb82c8b1de9dc0ce62d0eed4d676d21e1adfb4930832c5123abb
-SIZE (ioquake3-1.33.tar.bz2) = 2421997
+MD5 (ioquake3-1.33.797.tar.bz2) = 2bc968c6b73835657c7d2b4bf100c491
+SHA256 (ioquake3-1.33.797.tar.bz2) = 99cba27413bf5bc0b51f0ce4e55f51321ffe17ab5ca3bbd15837c85020c481c7
+SIZE (ioquake3-1.33.797.tar.bz2) = 2423661
diff --git a/games/ioquake3/files/patch-Makefile b/games/ioquake3/files/patch-Makefile
index 4830ebf93000..44f7516d43b2 100644
--- a/games/ioquake3/files/patch-Makefile
+++ b/games/ioquake3/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig Sat Apr 29 16:54:54 2006
-+++ ./Makefile Wed Jun 7 19:34:25 2006
+--- ./Makefile.orig Mon May 29 00:02:54 2006
++++ ./Makefile Sun Jun 11 17:26:26 2006
@@ -26,11 +26,19 @@
endif
endif
@@ -84,7 +84,7 @@
endif
- ifeq ($(USE_SDL),1)
-- BASE_CFLAGS += $(shell sdl11-config --cflags) -DUSE_SDL_VIDEO=1 -DUSE_SDL_SOUND=1
+- BASE_CFLAGS += $(shell sdl-config --cflags) -DUSE_SDL_VIDEO=1 -DUSE_SDL_SOUND=1
+ ifeq ($(USE_SDL_AUDIO),1)
+ BASE_CFLAGS += $(shell $(SDL_CONFIG) --cflags)
+ else
@@ -109,11 +109,11 @@
- BASE_CFLAGS += -DNO_VM_COMPILED
+ ifeq ($(USE_SDL_AUDIO),1)
+ BASE_CFLAGS += -DUSE_SDL_SOUND=1
- endif
++ endif
+
+ ifeq ($(USE_SDL_VIDEO),1)
+ BASE_CFLAGS += -DUSE_SDL_VIDEO=1
-+ endif
+ endif
+
+ ifeq ($(USE_OPTIMIZED_CFLAGS),1)
+ RELEASE_CFLAGS+=-O3 -ffast-math -funroll-loops -fomit-frame-pointer \
@@ -135,14 +135,13 @@
- THREAD_LDFLAGS=-lpthread
+ THREAD_LDFLAGS=$(PTHREAD_LIBS)
# don't need -ldl (FreeBSD)
-- LDFLAGS=-lm
-+ LDFLAGS+=-lm
+ LDFLAGS=-lm
- CLIENT_LDFLAGS =
+ CLIENT_LDFLAGS = -L$(LOCALBASE)/lib
- ifeq ($(USE_SDL),1)
-- CLIENT_LDFLAGS += $(shell sdl11-config --libs)
+- CLIENT_LDFLAGS += $(shell sdl-config --libs)
+ ifeq ($(USE_SDL_AUDIO),1)
+ CLIENT_LDFLAGS += $(shell $(SDL_CONFIG) --libs)
else
@@ -164,7 +163,15 @@
endif
endif
-@@ -632,24 +629,24 @@
+@@ -478,7 +475,6 @@
+ CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
+ endif
+
+-
+ else # ifeq freebsd
+
+ #############################################################################
+@@ -632,24 +628,24 @@
TARGETS =
ifneq ($(BUILD_SERVER),0)
@@ -198,7 +205,7 @@
endif
ifneq ($(BUILD_GAME_QVM),0)
-@@ -707,11 +704,11 @@
+@@ -707,11 +703,11 @@
$(MAKE) targets B=$(BD) CFLAGS="$(CFLAGS) $(DEBUG_CFLAGS) $(DEPEND_CFLAGS)"
build_release: B=$(BR)
@@ -212,7 +219,7 @@
targets: $(TARGETS)
-@@ -919,11 +916,11 @@
+@@ -919,11 +915,11 @@
$(B)/client/ftola.o \
$(B)/client/snapvectora.o
endif
@@ -226,7 +233,7 @@
ifneq ($(VM_PPC),)
Q3OBJ += $(B)/client/$(VM_PPC).o
endif
-@@ -971,10 +968,10 @@
+@@ -971,10 +967,10 @@
$(B)/client/sdl_glimp_smp.o
endif
@@ -239,7 +246,7 @@
$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
$(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
-@@ -1253,17 +1250,17 @@
+@@ -1253,17 +1249,17 @@
$(B)/ded/snapvectora.o $(B)/ded/matha.o
endif
@@ -260,7 +267,7 @@
$(CC) -o $@ $(Q3DOBJ) $(LDFLAGS)
$(B)/ded/sv_bot.o : $(SDIR)/sv_bot.c; $(DO_DED_CC)
-@@ -1377,7 +1374,7 @@
+@@ -1377,7 +1373,7 @@
Q3CGOBJ = $(Q3CGOBJ_) $(B)/baseq3/cgame/cg_syscalls.o
Q3CGVMOBJ = $(Q3CGOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -269,7 +276,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3CGOBJ)
$(B)/baseq3/vm/cgame.qvm: $(Q3CGVMOBJ) $(CGDIR)/cg_syscalls.asm
-@@ -1418,7 +1415,7 @@
+@@ -1418,7 +1414,7 @@
MPCGOBJ = $(MPCGOBJ_) $(B)/missionpack/cgame/cg_syscalls.o
MPCGVMOBJ = $(MPCGOBJ_:%.o=%.asm) $(B)/missionpack/game/bg_lib.asm
@@ -278,7 +285,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPCGOBJ)
$(B)/missionpack/vm/cgame.qvm: $(MPCGVMOBJ) $(CGDIR)/cg_syscalls.asm
-@@ -1468,7 +1465,7 @@
+@@ -1468,7 +1464,7 @@
Q3GOBJ = $(Q3GOBJ_) $(B)/baseq3/game/g_syscalls.o
Q3GVMOBJ = $(Q3GOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -287,7 +294,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3GOBJ)
$(B)/baseq3/vm/qagame.qvm: $(Q3GVMOBJ) $(GDIR)/g_syscalls.asm
-@@ -1516,7 +1513,7 @@
+@@ -1516,7 +1512,7 @@
MPGOBJ = $(MPGOBJ_) $(B)/missionpack/game/g_syscalls.o
MPGVMOBJ = $(MPGOBJ_:%.o=%.asm) $(B)/missionpack/game/bg_lib.asm
@@ -296,7 +303,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPGOBJ)
$(B)/missionpack/vm/qagame.qvm: $(MPGVMOBJ) $(GDIR)/g_syscalls.asm
-@@ -1576,7 +1573,7 @@
+@@ -1576,7 +1572,7 @@
Q3UIOBJ = $(Q3UIOBJ_) $(B)/missionpack/ui/ui_syscalls.o
Q3UIVMOBJ = $(Q3UIOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -305,7 +312,7 @@
$(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(Q3UIOBJ)
$(B)/baseq3/vm/ui.qvm: $(Q3UIVMOBJ) $(UIDIR)/ui_syscalls.asm
-@@ -1601,7 +1598,7 @@
+@@ -1601,7 +1597,7 @@
MPUIOBJ = $(MPUIOBJ_) $(B)/missionpack/ui/ui_syscalls.o
MPUIVMOBJ = $(MPUIOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
diff --git a/games/ioquake3/files/patch-code__botlib__be_interface.c b/games/ioquake3/files/patch-code__botlib__be_interface.c
index dd57f36a808f..45e7f5e21246 100644
--- a/games/ioquake3/files/patch-code__botlib__be_interface.c
+++ b/games/ioquake3/files/patch-code__botlib__be_interface.c
@@ -1,5 +1,5 @@
--- ./code/botlib/be_interface.c.orig Wed Apr 26 10:36:58 2006
-+++ ./code/botlib/be_interface.c Wed Jun 7 19:34:25 2006
++++ ./code/botlib/be_interface.c Sun Jun 11 17:26:26 2006
@@ -155,7 +155,7 @@
} else {
Com_sprintf(logfilename, sizeof(logfilename), "botlib.log");
diff --git a/games/ioquake3/files/patch-code__qcommon__common.c b/games/ioquake3/files/patch-code__qcommon__common.c
index c1fdcacdd58a..6899017952d4 100644
--- a/games/ioquake3/files/patch-code__qcommon__common.c
+++ b/games/ioquake3/files/patch-code__qcommon__common.c
@@ -1,5 +1,5 @@
--- ./code/qcommon/common.c.orig Wed Apr 26 08:27:12 2006
-+++ ./code/qcommon/common.c Wed Jun 7 19:34:25 2006
++++ ./code/qcommon/common.c Sun Jun 11 17:26:26 2006
@@ -25,6 +25,7 @@
#include "qcommon.h"
#include <setjmp.h>
diff --git a/games/ioquake3/files/patch-code__qcommon__q_platform.h b/games/ioquake3/files/patch-code__qcommon__q_platform.h
index c65c0b6f3705..543c8d5710ed 100644
--- a/games/ioquake3/files/patch-code__qcommon__q_platform.h
+++ b/games/ioquake3/files/patch-code__qcommon__q_platform.h
@@ -1,5 +1,5 @@
--- ./code/qcommon/q_platform.h.orig Tue Dec 27 16:46:01 2005
-+++ ./code/qcommon/q_platform.h Wed Jun 7 19:35:23 2006
++++ ./code/qcommon/q_platform.h Sun Jun 11 17:26:26 2006
@@ -176,11 +176,7 @@
#define ID_INLINE inline
#define PATH_SEP '/'
diff --git a/games/ioquake3/files/patch-code__unix__linux_glimp.c b/games/ioquake3/files/patch-code__unix__linux_glimp.c
index 987afc280e72..00304f2b5be1 100644
--- a/games/ioquake3/files/patch-code__unix__linux_glimp.c
+++ b/games/ioquake3/files/patch-code__unix__linux_glimp.c
@@ -1,5 +1,5 @@
--- ./code/unix/linux_glimp.c.orig Sun Apr 30 11:32:56 2006
-+++ ./code/unix/linux_glimp.c Wed Jun 7 19:34:25 2006
++++ ./code/unix/linux_glimp.c Sun Jun 11 17:26:26 2006
@@ -631,8 +631,14 @@
dx = ((int)event.xmotion.x - mwx);
diff --git a/games/ioquake3/files/patch-code__unix__unix_main.c b/games/ioquake3/files/patch-code__unix__unix_main.c
index cd61c56a765f..f539c9649a95 100644
--- a/games/ioquake3/files/patch-code__unix__unix_main.c
+++ b/games/ioquake3/files/patch-code__unix__unix_main.c
@@ -1,5 +1,5 @@
--- ./code/unix/unix_main.c.orig Sun Feb 26 18:22:12 2006
-+++ ./code/unix/unix_main.c Wed Jun 7 19:34:25 2006
++++ ./code/unix/unix_main.c Sun Jun 11 17:26:26 2006
@@ -774,6 +774,7 @@
char curpath[MAX_OSPATH];
char fname[MAX_OSPATH];
diff --git a/games/ioquake3/pkg-message b/games/ioquake3/pkg-message
new file mode 100644
index 000000000000..581f11640146
--- /dev/null
+++ b/games/ioquake3/pkg-message
@@ -0,0 +1,10 @@
+==============================================================================
+
+If you have sound problems with SDL try setting the variable "s_sdlSpeed" to
+"44100". It will be saved to the configuration file.
+
+If you have sound problems with OpenAL recompile without it. Also the OPENAL
+option causes the program to omit restoring gamma and mouse sensivity after
+exitting.
+
+==============================================================================