aboutsummaryrefslogtreecommitdiffstats
path: root/games/iourbanterror
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-09-12 12:34:48 +0800
committeralepulver <alepulver@FreeBSD.org>2007-09-12 12:34:48 +0800
commit5b8c079699941b82b737b76b63623943283beb96 (patch)
tree0a6ab152d2c60f6a13cf7efef4c32f7fea9e80a9 /games/iourbanterror
parentfb02329368b8b3bf1cac5130937037be5aa4e286 (diff)
downloadfreebsd-ports-gnome-5b8c079699941b82b737b76b63623943283beb96.tar.gz
freebsd-ports-gnome-5b8c079699941b82b737b76b63623943283beb96.tar.zst
freebsd-ports-gnome-5b8c079699941b82b737b76b63623943283beb96.zip
- Bump PORTREVISION.
- Remove FreeBSD 4.x support (USE_GCC=3.4+ and files/extra-patch-*). - Add USE_XLIB when using USE_GL, since it doesn't imply it anymore. - Use ~/.ioquake3 for writing instead of original ~/.q3a, because the new configuration files have more variables, and would be removed if overwriten by another engine. Note it in pkg-message. - Install README.
Diffstat (limited to 'games/iourbanterror')
-rw-r--r--games/iourbanterror/Makefile19
-rw-r--r--games/iourbanterror/files/extra-patch-code__unix__unix_shared.c24
-rw-r--r--games/iourbanterror/pkg-message5
-rw-r--r--games/iourbanterror/pkg-plist2
4 files changed, 16 insertions, 34 deletions
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index 22dcee35173c..c2f42bfbbec3 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ioquake3
DISTVERSION= 1.34-rc3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://ioquake3.org/files/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -16,7 +16,6 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= Cleaned-up and enhaced version of Quake 3
USE_BZIP2= yes
-USE_GCC= 3.4+
USE_GMAKE= yes
OPTIONS= CLIENT "Build client" on \
@@ -39,10 +38,6 @@ VM_ARCHS= amd64 i386 powerpc
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-code__unix__unix_shared.c
-.endif
-
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SMP)
IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
@@ -77,6 +72,7 @@ USE_SDL= sdl
MAKE_ENV+= USE_SDL_VIDEO=1
. else
USE_GL= yes
+USE_XLIB= yes
. endif
# Vorbis
. if defined(WITH_VORBIS)
@@ -120,11 +116,10 @@ Q3BIN+= ioquake3-smp
PLIST_SUB+= SMP="@comment "
.endif
-.if ${OSVERSION} < 500000
post-patch:
- @${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|' \
- ${BUILD_WRKSRC}/code/qcommon/q_shared.h
-.endif
+# There are new variables in the config files, so keep them in another dir.
+ @${REINPLACE_CMD} -E 's|/\.q3a|/.${PORTNAME}|' \
+ ${WRKSRC}/code/unix/unix_shared.c
do-install:
.for bin in ${Q3BIN}
@@ -136,6 +131,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/release/${dir}/*.so ${LIBDIR}/${dir}
.endfor
.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
post-install:
@${ECHO_CMD}
diff --git a/games/iourbanterror/files/extra-patch-code__unix__unix_shared.c b/games/iourbanterror/files/extra-patch-code__unix__unix_shared.c
deleted file mode 100644
index a0860384c25c..000000000000
--- a/games/iourbanterror/files/extra-patch-code__unix__unix_shared.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./code/unix/unix_shared.c.orig Fri Nov 4 19:32:00 2005
-+++ ./code/unix/unix_shared.c Wed Jun 7 16:52:01 2006
-@@ -20,6 +20,7 @@
- ===========================================================================
- */
- #include <sys/types.h>
-+#include <sys/sysctl.h>
- #include <sys/stat.h>
- #include <errno.h>
- #include <stdio.h>
-@@ -430,6 +431,12 @@
- // sysconf() in libc, POSIX.1 compliant
- unsigned int Sys_ProcessorCount(void)
- {
-- return sysconf(_SC_NPROCESSORS_ONLN);
-+ int mib[2], value, len;
-+
-+ mib[0] = CTL_HW;
-+ mib[1] = HW_NCPU;
-+ len = sizeof(value);
-+ sysctl(mib, 2, &value, &len, NULL, 0);
-+ return (value);
- }
- #endif
diff --git a/games/iourbanterror/pkg-message b/games/iourbanterror/pkg-message
index 581f11640146..a812c9d679ba 100644
--- a/games/iourbanterror/pkg-message
+++ b/games/iourbanterror/pkg-message
@@ -7,4 +7,9 @@ If you have sound problems with OpenAL recompile without it. Also the OPENAL
option causes the program to omit restoring gamma and mouse sensivity after
exitting.
+The configuration files are saved to ~/.ioquake3 instead of ~/.q3a because
+they have additional variables which would be removed if other engines
+overwrite them. But you can safely copy the original directory to the new one
+for the first time.
+
==============================================================================
diff --git a/games/iourbanterror/pkg-plist b/games/iourbanterror/pkg-plist
index a2fb5a77eb6c..d40d035630d5 100644
--- a/games/iourbanterror/pkg-plist
+++ b/games/iourbanterror/pkg-plist
@@ -7,6 +7,8 @@
%%GAMELIBS%%%%LIBDIR%%/missionpack/cgame.so
%%GAMELIBS%%%%LIBDIR%%/missionpack/qagame.so
%%GAMELIBS%%%%LIBDIR%%/missionpack/ui.so
+%%PORTDOCS%%%%DOCSDIR%%/README
%%GAMELIBS%%@dirrm %%LIBDIR%%/missionpack
%%GAMELIBS%%@dirrm %%LIBDIR%%/baseq3
%%GAMELIBS%%@dirrm %%LIBDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%