aboutsummaryrefslogtreecommitdiffstats
path: root/games/iourbanterror
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
committerpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
commitdfee6d5c62ab6b269042d70b16ee7a2529db951e (patch)
treebe83fbf870c86e4040bbca6fff53505cd1e7c8e2 /games/iourbanterror
parent4c40a810f99571b1f539a6fbd7c3a13147bb82c0 (diff)
downloadfreebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.gz
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.zst
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.zip
- Introduce USE_OPENAL variable for OpenAL consumers
- Switch to openal-soft as a default OpenAL implementation PR: ports/142123 Submitted by: mva Tested by: pointyhat exp-run Approved by: portmgr (hat)
Diffstat (limited to 'games/iourbanterror')
-rw-r--r--games/iourbanterror/Makefile4
-rw-r--r--games/iourbanterror/files/patch-code_client_snd_openal.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index a84c84abe2ac..8b6bb609a64b 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -7,7 +7,7 @@
PORTNAME= iourbanterror
DISTVERSION= 2007_12_20
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= http://ftp.snt.utwente.nl/pub/games/urbanterror/iourbanterror/source/complete/
DISTNAME= ioUrbanTerrorSource_${DISTVERSION}
@@ -78,7 +78,7 @@ MAKE_ENV+= USE_CURL_DLOPEN=1
. endif
# OpenAL
. if defined(WITH_OPENAL)
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
. if defined(WITH_OPENAL_DLOPEN)
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/iourbanterror/files/patch-code_client_snd_openal.c b/games/iourbanterror/files/patch-code_client_snd_openal.c
new file mode 100644
index 000000000000..e35fc7cbf9ac
--- /dev/null
+++ b/games/iourbanterror/files/patch-code_client_snd_openal.c
@@ -0,0 +1,11 @@
+--- code/client/snd_openal.c.orig 2009-12-26 18:12:52.000000000 +0100
++++ code/client/snd_openal.c 2009-12-26 18:13:00.000000000 +0100
+@@ -1676,7 +1676,7 @@
+ #elif defined(MACOS_X)
+ #define ALDRIVER_DEFAULT "/System/Library/Frameworks/OpenAL.framework/OpenAL"
+ #else
+-#define ALDRIVER_DEFAULT "libopenal.so.0"
++#define ALDRIVER_DEFAULT "libopenal.so"
+ #endif
+
+ /*