aboutsummaryrefslogtreecommitdiffstats
path: root/games/kapman
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /games/kapman
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'games/kapman')
-rw-r--r--games/kapman/Makefile23
-rw-r--r--games/kapman/distinfo2
-rw-r--r--games/kapman/pkg-descr9
-rw-r--r--games/kapman/pkg-plist43
4 files changed, 77 insertions, 0 deletions
diff --git a/games/kapman/Makefile b/games/kapman/Makefile
new file mode 100644
index 000000000000..207f7390dec8
--- /dev/null
+++ b/games/kapman/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= kapman
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+CONFLICTS_INSTALL= kdegames-4.[0-9].*
+
+USE_KDE4= kdehier kdelibs kdeprefix libkdegames automoc4
+USES= cmake:outsource
+USE_QT4= corelib gui xml \
+ moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+.include <${.CURDIR}/../kdegames4/Makefile.common>
+.include <bsd.port.mk>
diff --git a/games/kapman/distinfo b/games/kapman/distinfo
new file mode 100644
index 000000000000..ba4a3058c0f9
--- /dev/null
+++ b/games/kapman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.10.1/kapman-4.10.1.tar.xz) = f80515ca426998703fe103bcd86bdbb4b8ef4428e7aafdac1090844e6b5f37aa
+SIZE (KDE/4.10.1/kapman-4.10.1.tar.xz) = 1578084
diff --git a/games/kapman/pkg-descr b/games/kapman/pkg-descr
new file mode 100644
index 000000000000..f977965ee531
--- /dev/null
+++ b/games/kapman/pkg-descr
@@ -0,0 +1,9 @@
+Kapman is a clone of the well known game Pac-Man.
+
+You must run through the maze to eat all pills without being captured
+by a ghost. By eating an energizer, Kapman gets the ability to eat
+ghosts for a few seconds. When a stage is cleared of pills and
+energizer the player is taken to the next stage with slightly
+increased game speed.
+
+WWW: http://www.kde.org/applications/games/kapman/
diff --git a/games/kapman/pkg-plist b/games/kapman/pkg-plist
new file mode 100644
index 000000000000..816d877a642d
--- /dev/null
+++ b/games/kapman/pkg-plist
@@ -0,0 +1,43 @@
+bin/kapman
+share/applications/kde4/kapman.desktop
+share/apps/kapman/defaultmaze.xml
+share/apps/kapman/kapmanui.rc
+share/apps/kapman/themes/invisible.desktop
+share/apps/kapman/themes/invisible.svgz
+share/apps/kapman/themes/invisible_preview.png
+share/apps/kapman/themes/matches.desktop
+share/apps/kapman/themes/matches.svgz
+share/apps/kapman/themes/matches_preview.png
+share/apps/kapman/themes/mountain.copyright
+share/apps/kapman/themes/mountain.desktop
+share/apps/kapman/themes/mountain.svgz
+share/apps/kapman/themes/mountain_preview.png
+share/apps/kapman/themes/mummies_crypt.desktop
+share/apps/kapman/themes/mummies_crypt.svgz
+share/apps/kapman/themes/mummy_preview.png
+share/apps/kapman/themes/retro.desktop
+share/apps/kapman/themes/retro.svgz
+share/apps/kapman/themes/retro_preview.png
+share/doc/HTML/en/kapman/common
+share/doc/HTML/en/kapman/config.png
+share/doc/HTML/en/kapman/index.cache.bz2
+share/doc/HTML/en/kapman/index.docbook
+share/doc/HTML/en/kapman/kapman.png
+share/icons/hicolor/128x128/apps/kapman.png
+share/icons/hicolor/16x16/apps/kapman.png
+share/icons/hicolor/22x22/apps/kapman.png
+share/icons/hicolor/32x32/apps/kapman.png
+share/icons/hicolor/48x48/apps/kapman.png
+share/icons/hicolor/64x64/apps/kapman.png
+share/icons/hicolor/scalable/apps/kapman.svgz
+share/sounds/kapman/bonus.ogg
+share/sounds/kapman/energizer.ogg
+share/sounds/kapman/gameover.ogg
+share/sounds/kapman/ghost.ogg
+share/sounds/kapman/levelup.ogg
+share/sounds/kapman/life.ogg
+share/sounds/kapman/pill.ogg
+@dirrm share/sounds/kapman
+@dirrm share/doc/HTML/en/kapman
+@dirrm share/apps/kapman/themes
+@dirrm share/apps/kapman