aboutsummaryrefslogtreecommitdiffstats
path: root/games/kdegames4/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-02-18 22:23:03 +0800
committermakc <makc@FreeBSD.org>2014-02-18 22:23:03 +0800
commit2aba1fd14fd3e36b7ef5336e42b49b97805dcb91 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /games/kdegames4/Makefile
parent7574af52b853d1bbf2fcabfa2c04a4e1b98a4674 (diff)
downloadfreebsd-ports-gnome-2aba1fd14fd3e36b7ef5336e42b49b97805dcb91.tar.gz
freebsd-ports-gnome-2aba1fd14fd3e36b7ef5336e42b49b97805dcb91.tar.zst
freebsd-ports-gnome-2aba1fd14fd3e36b7ef5336e42b49b97805dcb91.zip
KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!
Among changes: - Switch KDE4_PREFIX to ${LOCALBASE} - Remove now needless misc/kde4-shared-mime-info port - Add stage support - Remove ancient CONFLICTS (KDE 4.9 and less) and LATEST_LINK - Squeeze MASTER_SITES/MASTER_SITE_SUBDIR - Convert LIB_DEPENDS to new style - Use options helpers - Drop support for FreeBSD 7.x - Remove Qt/KDE 3 related workarounds - Remove local patches and use upstream version scheme for libraries - sysutils/kdeadmin4, net/kdenetwork4, devel/kdesdk4, and x11-clocks/kdetoys4 ports have been split. - devel/kcachegrind is now a part of KDE SC [1] - more logs in area51 repo... New ports: devel/kde-dev-scripts: KDE development scripts devel/kde-dev-utils: KDE development utilities games/klickety: Tetris themed solitaire games/picmi: Single player logic-based puzzle game textproc/libkomparediff2: Library to compare files and strings The area51 repository features commits by Schaich Alonso, avilla, rakuco and myself. PR: ports/186491 Exp-run: by bdrewery Approved by: beat (former maintainer) [1]
Diffstat (limited to 'games/kdegames4/Makefile')
-rw-r--r--games/kdegames4/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/games/kdegames4/Makefile b/games/kdegames4/Makefile
index 9afd06cd996a..d30b4516bf41 100644
--- a/games/kdegames4/Makefile
+++ b/games/kdegames4/Makefile
@@ -2,38 +2,29 @@
PORTNAME= kdegames
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= games kde
DISTFILES= #
MAINTAINER= kde@FreeBSD.org
COMMENT= Games for KDE 4 (meta port)
-LATEST_LINK= ${PORTNAME}4
USE_KDE4= kdeprefix
NO_BUILD= yes
+NO_INSTALL= yes
+NO_MTREE= yes
-OPTIONS_DEFINE= ${KDE4_GAMES_ALL}
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+OPTIONS_DEFINE= ALL ${KDE4_GAMES_ALL}
+OPTIONS_DEFAULT= ALL
-NO_STAGE= yes
.include <${.CURDIR}/Makefile.common>
.for game in ${KDE4_GAMES_ALL}
+# _PORT, _DETECT, and _DESC are defined in Makefile.common
${game}_PORT?= games/${game}
${game}_DETECT?= ${KDE4_PREFIX}/bin/${game}
${game}_DESC?= Please fix a typo in option name/desc!
+${game}_RUN_DEPENDS= ${${game}_DETECT}:${PORTSDIR}/${${game}_PORT}
+ALL_RUN_DEPENDS+= ${${game}_RUN_DEPENDS}
.endfor
-.include <bsd.port.options.mk>
-
-.for game in ${KDE4_GAMES_ALL}
-. if ${PORT_OPTIONS:M${game}}
-RUN_DEPENDS+= ${${game}_DETECT}:${PORTSDIR}/${${game}_PORT}
-. endif
-.endfor
-
-do-install:
- ${DO_NADA}
-
.include <bsd.port.mk>