aboutsummaryrefslogtreecommitdiffstats
path: root/games/koth/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-17 02:46:41 +0800
committerpav <pav@FreeBSD.org>2004-10-17 02:46:41 +0800
commit73d365bd2e31e51f1928342ce13b05d6c89e23cb (patch)
tree9a4a4fc218765cfc5a5696408a60212307c01412 /games/koth/Makefile
parent8c641395a9070451be2268752a453f48832abbe1 (diff)
downloadfreebsd-ports-gnome-73d365bd2e31e51f1928342ce13b05d6c89e23cb.tar.gz
freebsd-ports-gnome-73d365bd2e31e51f1928342ce13b05d6c89e23cb.tar.zst
freebsd-ports-gnome-73d365bd2e31e51f1928342ce13b05d6c89e23cb.zip
Add KOTH (King of the Hill), a multiplayer tank artillery game similar to
Scorched Earth that uses libggi. PR: ports/72725 Submitted by: Travis Poppe <tlp@LiquidX.org>
Diffstat (limited to 'games/koth/Makefile')
-rw-r--r--games/koth/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/koth/Makefile b/games/koth/Makefile
new file mode 100644
index 000000000000..470f2806bfba
--- /dev/null
+++ b/games/koth/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: koth
+# Date created: 15 Oct 2004
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= koth
+PORTVERSION= 0.8.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR=games/multiplayer
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Multiplayer tank artillery game similar to Scorched Earth
+
+LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/kclever-ai bin/kmoron-ai bin/koth bin/koths
+MAN6= kclever-ai.6 kmoron-ai.6 koth.6 koths.6
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>