aboutsummaryrefslogtreecommitdiffstats
path: root/games/koth
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-12-10 07:29:36 +0800
committerpav <pav@FreeBSD.org>2004-12-10 07:29:36 +0800
commite6f0f463aa1ba941d77508f8f758a160ed72fd3d (patch)
tree075c287cc582d5dc585dcc36caabfe2d18349e9c /games/koth
parent35a2a6e46914f40f33ffd40281ee349509225a89 (diff)
downloadfreebsd-ports-gnome-e6f0f463aa1ba941d77508f8f758a160ed72fd3d.tar.gz
freebsd-ports-gnome-e6f0f463aa1ba941d77508f8f758a160ed72fd3d.tar.zst
freebsd-ports-gnome-e6f0f463aa1ba941d77508f8f758a160ed72fd3d.zip
- Fix build with recent libggi on 4.x
Reported by: krismail
Diffstat (limited to 'games/koth')
-rw-r--r--games/koth/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/koth/Makefile b/games/koth/Makefile
index 470f2806bfba..13c591ab9817 100644
--- a/games/koth/Makefile
+++ b/games/koth/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
PLIST_FILES= bin/kclever-ai bin/kmoron-ai bin/koth bin/koths
MAN6= kclever-ai.6 kmoron-ai.6 koth.6 koths.6
@@ -25,4 +26,7 @@ MAN6= kclever-ai.6 kmoron-ai.6 koth.6 koths.6
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lggi|-lggi ${PTHREAD_LIBS}|' ${WRKSRC}/configure
+
.include <bsd.port.mk>