aboutsummaryrefslogtreecommitdiffstats
path: root/games/kpat/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /games/kpat/Makefile
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'games/kpat/Makefile')
-rw-r--r--games/kpat/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/kpat/Makefile b/games/kpat/Makefile
new file mode 100644
index 000000000000..1129d679599a
--- /dev/null
+++ b/games/kpat/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= kpat
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+CONFLICTS_INSTALL= kdegames-4.[0-9].*
+
+USE_KDE4= kdehier kdelibs kdeprefix libkdegames automoc4 sharedmime
+USES= cmake:outsource
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
+ ${WRKSRC}/mimetypes/CMakeLists.txt
+
+.include <${.CURDIR}/../kdegames4/Makefile.common>
+.include <bsd.port.mk>