aboutsummaryrefslogtreecommitdiffstats
path: root/games/kpuzzle/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-09-03 02:09:03 +0800
committerarved <arved@FreeBSD.org>2004-09-03 02:09:03 +0800
commit8631ac22cb349fc54926e38e200c27012792c68a (patch)
treeaf6fbd74963b1d711155bd7aaa72fb62972d21da /games/kpuzzle/Makefile
parent833572cd3ba1821bb06ef4495bf57f287714d75f (diff)
downloadfreebsd-ports-gnome-8631ac22cb349fc54926e38e200c27012792c68a.tar.gz
freebsd-ports-gnome-8631ac22cb349fc54926e38e200c27012792c68a.tar.zst
freebsd-ports-gnome-8631ac22cb349fc54926e38e200c27012792c68a.zip
Readd kpuzzle, a Jigsaw puzzle game for KDE
Diffstat (limited to 'games/kpuzzle/Makefile')
-rw-r--r--games/kpuzzle/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/kpuzzle/Makefile b/games/kpuzzle/Makefile
new file mode 100644
index 000000000000..834f2c2b419f
--- /dev/null
+++ b/games/kpuzzle/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: kpuzzle
+# Date created: 2004-09-02
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= kpuzzle
+PORTVERSION= 0.4
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kpuzzle
+DISTNAME= ${PORTNAME}-${PORTVERSION}-final
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Jigsaw puzzle game for KDE
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_BZIP2= yes
+USE_KDELIBS_VER= 3
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,malloc.h,stdlib.h," \
+ ${WRKSRC}/src/highscore.cpp ${WRKSRC}/src/kpuzzlegame.cpp
+
+post-install:
+ ${RM} ${PREFIX}/share/doc/HTML/de/kpuzzle
+
+.include <bsd.port.mk>