aboutsummaryrefslogtreecommitdiffstats
path: root/games/kpuzzle
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-15 13:49:39 +0800
committerwill <will@FreeBSD.org>2001-04-15 13:49:39 +0800
commit8b843e966543862c872e8eee7be2e1e69ee876a7 (patch)
tree7f888fb4986bc778ba0910a5aa29f79848b866e8 /games/kpuzzle
parent5acaf65191561ad90a05014bb72d6b59bc790c37 (diff)
downloadfreebsd-ports-gnome-8b843e966543862c872e8eee7be2e1e69ee876a7.tar.gz
freebsd-ports-gnome-8b843e966543862c872e8eee7be2e1e69ee876a7.tar.zst
freebsd-ports-gnome-8b843e966543862c872e8eee7be2e1e69ee876a7.zip
Replace this completely broken port with something that works.
Also update to kpuzzle 0.2. Note that the hackery involved here to make NOPORTDOCS work can be revisited later, since there are much more elegant ways to do it (like changing the default install target's dependencies, and using INSTALL_TARGET in here to add docs to the install). BTW, I don't know how this port ever worked in the first place -- KDE 1.x and kde-qt-addon (for KDE 1.9x, which is pre-2.x) are totally unrelated.
Diffstat (limited to 'games/kpuzzle')
-rw-r--r--games/kpuzzle/Makefile78
-rw-r--r--games/kpuzzle/distinfo2
-rw-r--r--games/kpuzzle/pkg-plist51
3 files changed, 55 insertions, 76 deletions
diff --git a/games/kpuzzle/Makefile b/games/kpuzzle/Makefile
index 3176cc6f1392..0c4ec90ae6e1 100644
--- a/games/kpuzzle/Makefile
+++ b/games/kpuzzle/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kpuzzle
-PORTVERSION= 0.1
+PORTVERSION= 0.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= unstable/apps/games
@@ -14,82 +14,10 @@ MASTER_SITE_SUBDIR= unstable/apps/games
MAINTAINER= trevor@FreeBSD.org
BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
-
-LIB_DEPENDS= kde-qt-addon.4:${PORTSDIR}/x11-toolkits/kde-qt-addon \
- kdecore.3:${PORTSDIR}/x11/kdelibs11
-BROKEN= "kde-qt-addon was removed"
-
-GNU_AUTOCONF= yes
-USE_AUTOMAKE= yes
+USE_KDELIBS_VER=2
+GNU_CONFIGURE= yes
USE_BZIP2= yes
-#USE_X_PREFIX= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --with-extra-includes="${LOCALBASE}/include/" \
- --with-qt-includes="${QTDIR}/include/X11/qt/" \
- --enable-debug
-CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/X11/qt -I${PREFIX}/include" \
- KDEDIR=${LOCALBASE} \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
- MOC=${X11BASE}/bin/moc \
- QTDIR=${X11BASE}
-MAKE_ENV+= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/X11/qt -I${PREFIX}/include" \
- KDEDIR=${LOCALBASE} \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
- MOC=${X11BASE}/bin/moc \
- QTDIR=${X11BASE}
-PLIST= ${WRKDIR}/pkg-plist
-
-do-patch:
- ${PERL} -pi -e "s:/default/:/en/:g" ${WRKSRC}/kpuzzle/doc/Makefile.am
- ${PERL} -pi -e "s:lkdecore -lqt:lkdecore -lkde-qt-addon -lqt:g" ${WRKSRC}/kpuzzle/doc/Makefile.am
-
-do-configure:
- cd ${WRKSRC} && ${SETENV} KDEDIR=${LOCALBASE} PREFIX=${X11BASE} ./configure \
- --with-extra-includes=${LOCALBASE}/include \
- --with-qt-includes=${X11BASE}/include/X11/qt
-
-post-configure:
- ${PERL} -pi -e "s:MOC = /usr:MOC = ${X11BASE}:g" `find ${WRKSRC}/kpuzzle -name Makefile`
-
-pre-install:
- ${RM} -f ${PLIST}
- cd ${WRKSRC}/kpuzzle/pics/; \
- for i in *.xpm *.bmp; do \
- ${ECHO} share/apps/kpuzzle/data/$${i} >> ${PLIST}; \
- done
- cd ${WRKSRC}/kpuzzle/levels/; \
- for i in *.bmp; do \
- ${ECHO} share/apps/kpuzzle/levels/$${i} >> ${PLIST}; \
- done
- ${ECHO} share/applnk/Games/kpuzzle.kdelnk >> ${PLIST}
- ${ECHO} share/icons/kpuzzle.xpm >> ${PLIST}
- ${ECHO} share/icons/mini/mini-kpuzzle.xpm >> ${PLIST}
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}/kpuzzle/doc/; \
- for i in *html *gif; do \
- ${ECHO} share/doc/HTML/en/kpuzzle/$${i} >> ${PLIST}; \
- done
- ${ECHO} @dirrm /share/doc/HTML/en/kpuzzle >> ${PLIST}
-.endif
-.for i in share/apps/kpuzzle/data share/applnk/Games share/apps/kpuzzle/levels share/apps/kpuzzle
- ${ECHO} @dirrm ${i} >> ${PLIST}
-.endfor
-
-do-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/HTML/en/kpuzzle
- ${INSTALL_DATA} ${WRKSRC}/kpuzzle/doc/*.html ${PREFIX}/share/doc/HTML/en/kpuzzle
- ${INSTALL_DATA} ${WRKSRC}/kpuzzle/doc/scr_1.gif ${PREFIX}/share/doc/HTML/en/kpuzzle
-.endif
-.for i in share/applnk/Games share/apps/kpuzzle/data share/apps/kpuzzle/levels
- ${MKDIR} ${PREFIX}/${i}
-.endfor
- ${INSTALL_PROGRAM} ${WRKSRC}/kpuzzle/kpuzzle ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/kpuzzle/pics/*.xpm ${WRKSRC}/kpuzzle/pics/*.bmp ${PREFIX}/share/apps/kpuzzle/data/
- ${INSTALL_DATA} ${WRKSRC}/kpuzzle/levels/*.bmp ${PREFIX}/share/apps/kpuzzle/levels/
- ${INSTALL_DATA} ${WRKSRC}/kpuzzle/kpuzzle.kdelnk ${PREFIX}/share/applnk/Games
- ${INSTALL_DATA} ${WRKSRC}/kpuzzle/kpuzzle.xpm ${PREFIX}/share/icons
- ${INSTALL_DATA} ${WRKSRC}/kpuzzle/mini-kpuzzle.xpm ${PREFIX}/share/icons/mini
.include <bsd.port.mk>
diff --git a/games/kpuzzle/distinfo b/games/kpuzzle/distinfo
index bd16298fed74..25ea9c982895 100644
--- a/games/kpuzzle/distinfo
+++ b/games/kpuzzle/distinfo
@@ -1 +1 @@
-MD5 (kpuzzle-0.1.tar.bz2) = a7267dce1d244cbc67adede5f7e5db82
+MD5 (kpuzzle-0.2.tar.bz2) = a61b6b93b10fb7021c44dae64e0623f3
diff --git a/games/kpuzzle/pkg-plist b/games/kpuzzle/pkg-plist
new file mode 100644
index 000000000000..6279bb867e9f
--- /dev/null
+++ b/games/kpuzzle/pkg-plist
@@ -0,0 +1,51 @@
+bin/kpuzzle
+share/applnk/Games/kpuzzle.desktop
+share/apps/kpuzzle/data/biglogo.bmp
+share/apps/kpuzzle/data/large-main.xpm
+share/apps/kpuzzle/data/large.xpm
+share/apps/kpuzzle/data/lose.bmp
+share/apps/kpuzzle/data/newgame.xpm
+share/apps/kpuzzle/data/pause.bmp
+share/apps/kpuzzle/data/pause.xpm
+share/apps/kpuzzle/data/piece1-b.bmp
+share/apps/kpuzzle/data/piece1-l-b.bmp
+share/apps/kpuzzle/data/piece1-l-t.bmp
+share/apps/kpuzzle/data/piece1-l.bmp
+share/apps/kpuzzle/data/piece1-r-b.bmp
+share/apps/kpuzzle/data/piece1-r-t.bmp
+share/apps/kpuzzle/data/piece1-r.bmp
+share/apps/kpuzzle/data/piece1-t.bmp
+share/apps/kpuzzle/data/piece1.bmp
+share/apps/kpuzzle/data/piece2-b.bmp
+share/apps/kpuzzle/data/piece2-l-b.bmp
+share/apps/kpuzzle/data/piece2-l.bmp
+share/apps/kpuzzle/data/piece2-r-b.bmp
+share/apps/kpuzzle/data/piece2-r-t.bmp
+share/apps/kpuzzle/data/piece2-r.bmp
+share/apps/kpuzzle/data/piece2-t.bmp
+share/apps/kpuzzle/data/piece2.bmp
+share/apps/kpuzzle/data/stop.xpm
+share/apps/kpuzzle/data/win.bmp
+share/apps/kpuzzle/levels/electricity.bmp
+share/apps/kpuzzle/levels/foto1.bmp
+share/apps/kpuzzle/levels/foto2.bmp
+share/apps/kpuzzle/levels/foto3.bmp
+share/apps/kpuzzle/levels/foto4.bmp
+share/apps/kpuzzle/levels/foto5.bmp
+share/apps/kpuzzle/levels/geometry.bmp
+share/apps/kpuzzle/levels/plants.bmp
+share/apps/kpuzzle/levels/raum.bmp
+share/apps/kpuzzle/levels/stadt.bmp
+share/apps/kpuzzle/levels/stars.bmp
+share/doc/HTML/en/kpuzzle/common
+share/doc/HTML/en/kpuzzle/cont-1.html
+share/doc/HTML/en/kpuzzle/cont-2.html
+share/doc/HTML/en/kpuzzle/cont-3.html
+share/doc/HTML/en/kpuzzle/cont-4.html
+share/doc/HTML/en/kpuzzle/cont-5.html
+share/doc/HTML/en/kpuzzle/index.html
+share/doc/HTML/en/kpuzzle/scr_1.png
+share/icons/locolor/16x16/apps/kpuzzle.png
+share/icons/locolor/32x32/apps/kpuzzle.png
+share/locale/de/LC_MESSAGES/de.mo
+@dirrm share/doc/HTML/en/kpuzzle