aboutsummaryrefslogtreecommitdiffstats
path: root/games/kpuzzle
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /games/kpuzzle
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'games/kpuzzle')
-rw-r--r--games/kpuzzle/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/kpuzzle/Makefile b/games/kpuzzle/Makefile
index 47424223cef8..89a5b9babff5 100644
--- a/games/kpuzzle/Makefile
+++ b/games/kpuzzle/Makefile
@@ -15,13 +15,14 @@ MAINTAINER= kde@freebsd.org
USE_KDELIBS_VER= 2
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
post-patch:
- @${PERL} -pi -e 's|-O2||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
.for file in highscore.cpp kpuzzleapp.cpp
- @${PERL} -pi -e 's|#include <malloc.h>||g' ${WRKSRC}/kpuzzle/${file}
+ @${REINPLACE_CMD} -e 's|#include <malloc.h>||g' ${WRKSRC}/kpuzzle/${file}
.endfor
- @${PERL} -pi -e 's|default|en|g' ${WRKSRC}/kpuzzle/doc/en/Makefile.in
+ @${REINPLACE_CMD} -e 's|default|en|g' ${WRKSRC}/kpuzzle/doc/en/Makefile.in
.include <bsd.port.mk>