aboutsummaryrefslogtreecommitdiffstats
path: root/games/ksudoku
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
committermiwi <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
commitc486a60f04933c8227640b8faca0f931afbe32ef (patch)
tree827b6cdb889eaa1ccc00ca4598ae40dee1a42a50 /games/ksudoku
parent888eabb1977d6504355090d942963975c8d755ed (diff)
downloadfreebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.tar.gz
freebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.tar.zst
freebsd-ports-gnome-c486a60f04933c8227640b8faca0f931afbe32ef.zip
- Add common code to support for cmake based ports.
- Update devel/cmake to 2.6.0 (also fix ports/123092) - Use the new CMAKE build framework in all ports using cmake Approved by: portmgr (pav)
Diffstat (limited to 'games/ksudoku')
-rw-r--r--games/ksudoku/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/games/ksudoku/Makefile b/games/ksudoku/Makefile
index 47d4271e8ff2..feabf986127e 100644
--- a/games/ksudoku/Makefile
+++ b/games/ksudoku/Makefile
@@ -14,20 +14,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= freebsd@chillt.de
COMMENT= A Sudoku generator and solver for KDE
-BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
-
-CMAKE_ARGS= -DCMAKE_C_COMPILER:STRING="${CC}" \
- -DCMAKE_CXX_COMPILER:STRING="${CXX}" \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} ${PTHREAD_CFLAGS}" \
- -DCMAKE_EXE_LINKER_FLAGS:STRING="${PTHREAD_LIBS}" \
- -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX}
-
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_GL= yes
-
-do-configure:
- @cd ${WRKSRC} && \
- ${LOCALBASE}/bin/cmake ${CMAKE_ARGS}
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
.include <bsd.port.mk>