aboutsummaryrefslogtreecommitdiffstats
path: root/games/lander
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /games/lander
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'games/lander')
-rw-r--r--games/lander/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/lander/Makefile b/games/lander/Makefile
index d97c57c9e07f..9f5ea0765736 100644
--- a/games/lander/Makefile
+++ b/games/lander/Makefile
@@ -24,8 +24,8 @@ USE_GL= gl glu
MAKE_JOBS_SAFE= yes
USE_GCC= 4.2+
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-boost="${LOCALBASE}" \
--with-boost-filesystem=boost_filesystem