aboutsummaryrefslogtreecommitdiffstats
path: root/games/lbreakout2/Makefile
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2002-08-04 15:59:20 +0800
committermarkp <markp@FreeBSD.org>2002-08-04 15:59:20 +0800
commitcbeaa55a6c728320a0d630f76daac3f0ef8a9149 (patch)
tree57654ea5fd8f8f0748e842360f3966e527a77f61 /games/lbreakout2/Makefile
parent353753c36130e7bc2ac7b5581ff5cd6900935008 (diff)
downloadfreebsd-ports-gnome-cbeaa55a6c728320a0d630f76daac3f0ef8a9149.tar.gz
freebsd-ports-gnome-cbeaa55a6c728320a0d630f76daac3f0ef8a9149.tar.zst
freebsd-ports-gnome-cbeaa55a6c728320a0d630f76daac3f0ef8a9149.zip
Fix doc handling
Diffstat (limited to 'games/lbreakout2/Makefile')
-rw-r--r--games/lbreakout2/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/lbreakout2/Makefile b/games/lbreakout2/Makefile
index 182e6c694437..ee76fc82e7f9 100644
--- a/games/lbreakout2/Makefile
+++ b/games/lbreakout2/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-highscore-path=/var/games
+CONFIGURE_ARGS= --with-highscore-path=/var/games \
+ --with-doc-path=${PREFIX}/share/doc
CONFIGURE_ENV= SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
LDFLAGS=-L${LOCALBASE}/lib
USE_REINPLACE= yes
@@ -28,6 +29,9 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's/if .*lbreakout2.hscr/if false/' \
${WRKSRC}/src/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's/ docs / /g' ${WRKSRC}/src/Makefile.in
+.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/src/empty.hscr ${DATADIR}