aboutsummaryrefslogtreecommitdiffstats
path: root/games/lbreakout
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-03 07:41:51 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-03 07:41:51 +0800
commit977eaeb5eba4753f5481692c9dd692ecefd96e8d (patch)
tree66f9e928aacff87f10098769823d34de914217bd /games/lbreakout
parent98cd64620dc7a991ff2c533c2ec72298ad40657e (diff)
downloadfreebsd-ports-gnome-977eaeb5eba4753f5481692c9dd692ecefd96e8d.tar.gz
freebsd-ports-gnome-977eaeb5eba4753f5481692c9dd692ecefd96e8d.tar.zst
freebsd-ports-gnome-977eaeb5eba4753f5481692c9dd692ecefd96e8d.zip
- Add stage support
- Remove indefinite article from COMMENT - Convert USE_GMAKE to USES
Diffstat (limited to 'games/lbreakout')
-rw-r--r--games/lbreakout/Makefile13
-rw-r--r--games/lbreakout/pkg-plist8
2 files changed, 11 insertions, 10 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index 837af8dfe7be..d503b3a78bb9 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -8,14 +8,13 @@ CATEGORIES= games
MASTER_SITES= SF/lgames/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A nice clone of classical Breakout game
+COMMENT= Nice clone of classical Breakout game
USE_SDL= sdl
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-lcompat"
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
@@ -23,12 +22,6 @@ post-patch:
s|<SDL/SDL|<SDL|g'
pre-install:
- ${MKDIR} /var/games/${PORTNAME}
-
-post-install:
- ${CHOWN} root:games ${PREFIX}/bin/${PORTNAME}
- ${CHMOD} 2755 ${PREFIX}/bin/${PORTNAME}
- ${CHMOD} 664 /var/games/${PORTNAME}/${PORTNAME}.hscr
- ${CHOWN} root:games /var/games/${PORTNAME}/${PORTNAME}.hscr
+ ${MKDIR} ${STAGEDIR}/var/games/${PORTNAME}
.include <bsd.port.mk>
diff --git a/games/lbreakout/pkg-plist b/games/lbreakout/pkg-plist
index 0c1adf0c4075..380705cead15 100644
--- a/games/lbreakout/pkg-plist
+++ b/games/lbreakout/pkg-plist
@@ -1,4 +1,8 @@
+@group games
+@mode 2755
bin/lbreakout
+@mode
+@group
share/lbreakout/ball.bmp
share/lbreakout/bkgnd0.bmp
share/lbreakout/bkgnd1.bmp
@@ -45,5 +49,9 @@ share/lbreakout/weapon.wav
share/lbreakout/wontgiveup.wav
@dirrm share/lbreakout
@cwd /var/games
+@group games
+@mode 664
lbreakout/lbreakout.hscr
+@mode
+@group
@dirrm lbreakout