aboutsummaryrefslogtreecommitdiffstats
path: root/games/lbreakout
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
commit6e2b9def0c49c3e565a14f5987fd3e9f46d285c6 (patch)
treec23d8d7c62c20c0978b7a404b38eb7b9d5596d0f /games/lbreakout
parentfaa774bb672904227e681f88c16cfceef448ef6c (diff)
downloadfreebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.gz
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.zst
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Diffstat (limited to 'games/lbreakout')
-rw-r--r--games/lbreakout/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index db895af96ced..663e60048260 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= LIBS="-lcompat" \
SDL_CONFIG="${SDL_CONFIG}"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
xargs ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'