aboutsummaryrefslogtreecommitdiffstats
path: root/games/lgeneral
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 00:35:45 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 00:35:45 +0800
commitb0ad879e3e23b8ba6d75396d593d1bba436ffed6 (patch)
tree8b078441d20301eb3b13f3b6b3a374c4688468a4 /games/lgeneral
parent624c78988bf68a8f633b795635f8ba4b2fffed13 (diff)
downloadfreebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.tar.gz
freebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.tar.zst
freebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.zip
Convert to new options framework
Diffstat (limited to 'games/lgeneral')
-rw-r--r--games/lgeneral/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/games/lgeneral/Makefile b/games/lgeneral/Makefile
index 4ce14a971309..149aa6138157 100644
--- a/games/lgeneral/Makefile
+++ b/games/lgeneral/Makefile
@@ -20,8 +20,9 @@ LICENSE= GPLv2
CONFLICTS= lgeneral-data-[0-9]*
-OPTIONS= SOUND "Enable sound support" on \
- NLS "Enable native language support" on
+OPTIONS_DEFINE= SOUND NLS DOCS
+OPTIONS_DEFAULT= SOUND
+SOUND_DESC= Enable sound support
USE_SDL= sdl
USE_GMAKE= yes
@@ -36,19 +37,19 @@ MAN6= lgeneral.6
.include <bsd.port.options.mk>
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+=--disable-sound
-.else
+.if ${PORT_OPTIONS:MSOUND}
USE_SDL+= mixer
+.else
+CONFIGURE_ARGS+=--disable-sound
.endif
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ENV+= am_cv_func_iconv=no
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
.include <bsd.port.pre.mk>
@@ -65,7 +66,7 @@ post-install:
@${FIND} ${DATADIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
@${FIND} ${DATADIR} -type d | ${XARGS} ${CHMOD} a+rx
@${FIND} ${DATADIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.* ${DOCSDIR}
.endif
00:22:13 +0800'>2006-05-021-0/+2 * Conversion to a single libtool environment.ade2006-02-232-1/+4 * Remove the FreeBSD KEYWORD from all rc.d scripts where it appears.dougb2006-02-211-1/+0 * SHA256ifyedwin2006-01-231-0/+1 * Mass-conversion to the USE_AUTOTOOLS New World Order. The code presentade2005-11-151-1/+1 * Correct LDFLAGS after adding USE_GETOPT_LONG.marcus2005-07-041-2/+2 * Add USE_GETOPT_LONG to fix the build on 4.X.marcus2005-07-041-0/+1 * Update to 1.0.0, and change references of Rendezvous to Bonjour.marcus2005-07-034-6/+6 * * Update to 0.9.10marcus2005-01-304-12/+50 * Now that howl's pkg-config file has been fixed, we no longer need to hackmarcus2005-01-252-27/+26 * Update to 0.9.8, and fix the build on 4.X Alpha.marcus2005-01-253-27/+27 * BROKEN on alpha: Does not compilekris2005-01-021-1/+7 * Update to 0.9.7 which incorporates the previously committed portabilitymarcus2004-11-024-38/+3 * Add patches to fix mDNSResponder on FreeBSD. These patches have beenmarcus2004-11-013-0/+35 * Update to 0.9.6.marcus2004-08-188-145/+16 * Fix build with non-i386 architectures, and fix the installation path formarcus2004-07-216-32/+154 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-101-1/+1 * Update to 0.9.5.marcus2004-06-243-43/+40 * - Use pkgconfig PREFIXkrion2004-05-313-3/+18 * - Fix build on 4-xkrion2004-04-152-0/+16 * - Update to 0.9.4krion2004-04-113-48/+44 * SIZEify (maintainer timeout)trevor2004-03-311-0/+1 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-141-1/+1 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * - Update to 0.9.1clement2004-01-173-13/+20 * - Update to 0.8.1sergei2003-11-193-30/+36 * Set ONLY_FOR_ARCHS=i386.maho2003-10-251-0/+1 * New Port: howl 0.6.1: zerconf/rendezvous implementationedwin2003-08-241-2/+2