aboutsummaryrefslogtreecommitdiffstats
path: root/games/lgeneral
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 00:35:45 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 00:35:45 +0800
commitb0ad879e3e23b8ba6d75396d593d1bba436ffed6 (patch)
tree8b078441d20301eb3b13f3b6b3a374c4688468a4 /games/lgeneral
parent624c78988bf68a8f633b795635f8ba4b2fffed13 (diff)
downloadfreebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.tar.gz
freebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.tar.zst
freebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.zip
Convert to new options framework
Diffstat (limited to 'games/lgeneral')
-rw-r--r--games/lgeneral/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/games/lgeneral/Makefile b/games/lgeneral/Makefile
index 4ce14a971309..149aa6138157 100644
--- a/games/lgeneral/Makefile
+++ b/games/lgeneral/Makefile
@@ -20,8 +20,9 @@ LICENSE= GPLv2
CONFLICTS= lgeneral-data-[0-9]*
-OPTIONS= SOUND "Enable sound support" on \
- NLS "Enable native language support" on
+OPTIONS_DEFINE= SOUND NLS DOCS
+OPTIONS_DEFAULT= SOUND
+SOUND_DESC= Enable sound support
USE_SDL= sdl
USE_GMAKE= yes
@@ -36,19 +37,19 @@ MAN6= lgeneral.6
.include <bsd.port.options.mk>
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+=--disable-sound
-.else
+.if ${PORT_OPTIONS:MSOUND}
USE_SDL+= mixer
+.else
+CONFIGURE_ARGS+=--disable-sound
.endif
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ENV+= am_cv_func_iconv=no
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
.include <bsd.port.pre.mk>
@@ -65,7 +66,7 @@ post-install:
@${FIND} ${DATADIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
@${FIND} ${DATADIR} -type d | ${XARGS} ${CHMOD} a+rx
@${FIND} ${DATADIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.* ${DOCSDIR}
.endif