aboutsummaryrefslogtreecommitdiffstats
path: root/games/libggz/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-10-09 09:33:12 +0800
committerijliao <ijliao@FreeBSD.org>2003-10-09 09:33:12 +0800
commit4e56ba69876ce5746329cd8edf65d973bd18a263 (patch)
treefb45bc09fbcb8e0f24b403a412bae53e24ba653c /games/libggz/Makefile
parent967a6dda33e3c66e8f463f7aa7396c61c79d4600 (diff)
downloadfreebsd-ports-gnome-4e56ba69876ce5746329cd8edf65d973bd18a263.tar.gz
freebsd-ports-gnome-4e56ba69876ce5746329cd8edf65d973bd18a263.tar.zst
freebsd-ports-gnome-4e56ba69876ce5746329cd8edf65d973bd18a263.zip
add libggz 0.0.7
The GGZ Gaming Zone - Base Library
Diffstat (limited to 'games/libggz/Makefile')
-rw-r--r--games/libggz/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
new file mode 100644
index 000000000000..c15701d3bc81
--- /dev/null
+++ b/games/libggz/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: libggz
+# Date created: Oct 8, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libggz
+PORTVERSION= 0.0.7
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ggz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The GGZ Gaming Zone - Base Library
+
+LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ARGS= --disable-debug --with-gcrypt --with-tls
+
+INSTALLS_SHLIB= yes
+
+MAN3= ggz.h.3
+
+.include <bsd.port.mk>