aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-darwinia-demo/Makefile
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /games/linux-darwinia-demo/Makefile
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'games/linux-darwinia-demo/Makefile')
-rw-r--r--games/linux-darwinia-demo/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/games/linux-darwinia-demo/Makefile b/games/linux-darwinia-demo/Makefile
index 425f4e9292de..a5b6826381de 100644
--- a/games/linux-darwinia-demo/Makefile
+++ b/games/linux-darwinia-demo/Makefile
@@ -12,8 +12,8 @@ MAINTAINER= mva@FreeBSD.org
COMMENT= Real-time action strategy with programs
ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= yes
-USE_LINUX_APPS= sdl12 libogg libvorbis xorglibs
+USES= linux
+USE_LINUX= sdl12 libogg libvorbis xorglibs
NO_CDROM= Redistribution is limited, see license
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -28,24 +28,21 @@ NVIDIA_DESC= Enable nvidia graphics driver support
.if ${PORT_OPTIONS:MNVIDIA}
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX_APPS+=libglu
+USE_LINUX+= libglu
.else
-USE_LINUX_APPS+=dri
+USE_LINUX+= dri
.endif
do-extract:
@cd ${WRKSRC} && ${TAIL} +376 ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
${TAR} zxf -
-do-build:
- ${BRANDELF} -t Linux ${WRKSRC}/lib/darwinia.bin.x86
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
@cd ${WRKSRC}/lib && \
${INSTALL_PROGRAM} darwinia.bin.x86 ${STAGEDIR}${DATADIR} && \
${INSTALL_DATA} *.dat open-www.sh ${STAGEDIR}${DATADIR}
- ${INSTALL_PROGRAM} ${WRKDIR}/darwinia \
+ ${INSTALL_SCRIPT} ${WRKDIR}/darwinia \
${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}darwinia
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/LICENSE ${STAGEDIR}${DOCSDIR}/LICENSE