aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-rtcw
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-11-04 05:47:46 +0800
committertijl <tijl@FreeBSD.org>2016-11-04 05:47:46 +0800
commit808a2a60e7ce4e240588eba08e4f2ce6983b0e1f (patch)
tree217b630c3b537320d8bc0fa8c4a97dc39f4fd98c /games/linux-rtcw
parent14073edcb9a2d2648cbfb211f88a8fda5e7972f6 (diff)
downloadfreebsd-ports-gnome-808a2a60e7ce4e240588eba08e4f2ce6983b0e1f.tar.gz
freebsd-ports-gnome-808a2a60e7ce4e240588eba08e4f2ce6983b0e1f.tar.zst
freebsd-ports-gnome-808a2a60e7ce4e240588eba08e4f2ce6983b0e1f.zip
Remove NVIDIA option from Linux ports now that the nvidia-driver can be
installed later.
Diffstat (limited to 'games/linux-rtcw')
-rw-r--r--games/linux-rtcw/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/games/linux-rtcw/Makefile b/games/linux-rtcw/Makefile
index a4cb91ad0b5e..99108078081c 100644
--- a/games/linux-rtcw/Makefile
+++ b/games/linux-rtcw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rtcw
DISTVERSION= 1.41b
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games linux
MASTER_SITES= IDSOFTWARE/wolf/linux
PKGNAMEPREFIX= linux-
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Return to Castle Wolfenstein (Linux version)
USES= linux makeself
-USE_LINUX= xorglibs
+USE_LINUX= dri xorglibs
NO_WRKSUBDIR= yes
WRAPPERS= wolf wolfded wolfsp
@@ -24,16 +24,7 @@ PORTSCOUT= skipv:1.41-3
PORTDOCS= *
-OPTIONS_DEFINE= DOCS NVIDIA_GL
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNVIDIA_GL}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_EXTVER= '__GL_ExtensionStringVersion=18999 '
-.else
-USE_LINUX+= dri
-.endif
+OPTIONS_DEFINE= DOCS
# XXX: should probably be converted to use the LICENSE framework
post-extract:
@@ -43,7 +34,7 @@ do-build:
.for f in ${WRAPPERS}
(${ECHO_CMD} "#!${SH}"; ${ECHO_CMD}; \
${ECHO_CMD} "cd ${DATADIR} || exit 1"; \
- ${ECHO_CMD} '${NVIDIA_GL_EXTVER}exec ./${f} "$$@"') > ${WRKDIR}/${f}
+ ${ECHO_CMD} 'exec ./${f} "$$@"') > ${WRKDIR}/${f}
.endfor
do-install: