aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-savage
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-09-20 22:18:44 +0800
committeracm <acm@FreeBSD.org>2006-09-20 22:18:44 +0800
commit665818a1a29542f5a322a879190c9654eda5dc63 (patch)
tree5be23617e62f523c80dd9754369f98a597caeafe /games/linux-savage
parent0d0acfc30e354795f44ab4123d76c2a126ef5c23 (diff)
downloadfreebsd-ports-gnome-665818a1a29542f5a322a879190c9654eda5dc63.tar.gz
freebsd-ports-gnome-665818a1a29542f5a322a879190c9654eda5dc63.tar.zst
freebsd-ports-gnome-665818a1a29542f5a322a879190c9654eda5dc63.zip
- Fix the linux-savage script. Now it uses silverback instead of savage
- Add NVIDIA option - Add missing dependency - Bump PORTREVISION
Diffstat (limited to 'games/linux-savage')
-rw-r--r--games/linux-savage/Makefile17
-rw-r--r--games/linux-savage/files/savage.in2
2 files changed, 17 insertions, 2 deletions
diff --git a/games/linux-savage/Makefile b/games/linux-savage/Makefile
index ab02133414a5..b0ab70e1c166 100644
--- a/games/linux-savage/Makefile
+++ b/games/linux-savage/Makefile
@@ -7,6 +7,7 @@
PORTNAME= savage
PORTVERSION= 2.00c
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= http://downloads.s2games.com/online_orders/:full \
http://patches.s2games.com/:patch
@@ -38,6 +39,20 @@ SUB_FILES= pkg-message savage savage_editor savage_server
PLIST_SUB+= SAVAGEDIR="${SAVAGEDIR}"
SUB_LIST+= SAVAGEDIR="${PREFIX}/${SAVAGEDIR}"
+OPTIONS= NVIDIA "Install support for nvidia (You need a nvidia graphic card)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NVIDIA)
+. if !exists(${LINUXBASE}/usr/lib/libGL.so.1)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+. endif
+.else
+. if !exists(${LINUXBASE}/usr/X11R6/lib/libGL.so.1)
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+. endif
+.endif
+
do-extract:
# Extract savage base
@${MKDIR} ${WRKSRC}
@@ -96,4 +111,4 @@ post-install:
@PKG_PREFIX=${PREFIX}/${SAVAGEDIR} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/linux-savage/files/savage.in b/games/linux-savage/files/savage.in
index 283a2da83d29..018c6a20093b 100644
--- a/games/linux-savage/files/savage.in
+++ b/games/linux-savage/files/savage.in
@@ -2,4 +2,4 @@
cd %%SAVAGEDIR%% || exit 1
export LD_LIBRARY_PATH=libs:$LD_LIBRARY_PATH
-exec ./savage.bin "$@"
+exec ./silverback.bin "$@"