aboutsummaryrefslogtreecommitdiffstats
path: root/games/linwarrior
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-04-15 08:14:18 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-04-15 08:14:18 +0800
commitd6baa1282fe19b2644bd05b07833f8aa63a91f53 (patch)
tree64f6e7d6a1662ca3e986b9c8488d0633100989bf /games/linwarrior
parent11a6ae2a4c84f0f03906852d63a25587d4843f1a (diff)
downloadfreebsd-ports-gnome-d6baa1282fe19b2644bd05b07833f8aa63a91f53.tar.gz
freebsd-ports-gnome-d6baa1282fe19b2644bd05b07833f8aa63a91f53.tar.zst
freebsd-ports-gnome-d6baa1282fe19b2644bd05b07833f8aa63a91f53.zip
- Fix build on < 8.x
Reported by: pointyhat via pav
Diffstat (limited to 'games/linwarrior')
-rw-r--r--games/linwarrior/Makefile8
-rw-r--r--games/linwarrior/files/extra-patch-source-cMech.cpp21
2 files changed, 1 insertions, 28 deletions
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index ea4800849f4b..53a826fd24ae 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -31,12 +31,6 @@ DESKTOP_ENTRIES="LinWarrior 3D" \
"Game;ActionGame;Simulation;" \
false
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800007
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-source-cMech.cpp
-.endif
-
post-extract:
@${FIND} ${WRKSRC} -type d -exec chmod a+rx {} \;
@${FIND} ${WRKSRC} -type f -exec chmod a+r {} \;
@@ -51,4 +45,4 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC}/data && ${COPYTREE_SHARE} '*' ${DATADIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/linwarrior/files/extra-patch-source-cMech.cpp b/games/linwarrior/files/extra-patch-source-cMech.cpp
deleted file mode 100644
index 54f4677a9113..000000000000
--- a/games/linwarrior/files/extra-patch-source-cMech.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
---- source/cMech.cpp.orig 2009-11-08 16:18:05.000000000 +0300
-+++ source/cMech.cpp 2009-11-12 07:03:04.000000000 +0300
-@@ -1494,9 +1494,15 @@
- // Set XYZ to Not-A-Number (NaN) for no location.
- // Note that NaN-ity can only be tested either by
- // isnanf(x), !finite(x) or by x!=x as NaN always != NaN.
-- mDestination[0] = nanf("");
-- mDestination[1] = nanf("");
-- mDestination[2] = nanf("");
-+ union { /* from src/lib/msun/src/s_nan.c of FreeBSD HEAD */
-+ float f;
-+ uint32_t bits[1];
-+ } u;
-+ u.bits[0] = 0x7fc00000;
-+ mDestination[0] = u.f;
-+ mDestination[1] = u.f;
-+ mDestination[2] = u.f;
-+
- //cout << "Destination is " << ((finitef(mDestination[0])) ? "finite" : "infinite" ) << "\n";
- }
- }