aboutsummaryrefslogtreecommitdiffstats
path: root/games/lordsawar
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-06-25 12:15:50 +0800
committerak <ak@FreeBSD.org>2012-06-25 12:15:50 +0800
commit60979559fcb0d746133013f327e5d5e06658a074 (patch)
tree405353c9080123863f2fedaa42e8801637968ae4 /games/lordsawar
parent77abb0bc8cfedd52e471c22b28566de4364f658c (diff)
downloadfreebsd-ports-gnome-60979559fcb0d746133013f327e5d5e06658a074.tar.gz
freebsd-ports-gnome-60979559fcb0d746133013f327e5d5e06658a074.tar.zst
freebsd-ports-gnome-60979559fcb0d746133013f327e5d5e06658a074.zip
- Convert to optionsNG
- Pet portlint - Remove pkg-plist from security/dropbear Approved by: eadler (mentor)
Diffstat (limited to 'games/lordsawar')
-rw-r--r--games/lordsawar/Makefile25
1 files changed, 7 insertions, 18 deletions
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
index f16782627697..1882aac506ae 100644
--- a/games/lordsawar/Makefile
+++ b/games/lordsawar/Makefile
@@ -15,36 +15,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ak@FreeBSD.org
COMMENT= A Warlords II clone
-LIB_DEPENDS= glademm-2.4:${PORTSDIR}/devel/libglademm24 \
- gnet-2.0:${PORTSDIR}/net/gnet2 \
- uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
- tar.0:${PORTSDIR}/devel/libtar
+LICENSE= GPLv3
+
+LIB_DEPENDS= glademm-2:${PORTSDIR}/devel/libglademm24 \
+ gnet-2:${PORTSDIR}/net/gnet2 \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ tar:${PORTSDIR}/devel/libtar
BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_GETTEXT= yes
-USE_GCC= 4.2+
USE_GMAKE= yes
USE_GNOME= intltool
-USE_SDL= sdl image
+USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-LICENSE= GPLv3
-
-OPTIONS= SOUND "Enable sound" on
-
-.include <bsd.port.options.mk>
-
CONFIGURE_ARGS+=--disable-nls \
--with-boost-includedir=${LOCALBASE}/include/
-.if !defined(WITHOUT_SOUND)
-USE_SDL+= mixer
-.else
-CONFIGURE_ARGS+=--disable-sound
-.endif
-
CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib