aboutsummaryrefslogtreecommitdiffstats
path: root/games/lostfeathers
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-01-16 20:46:13 +0800
committernemysis <nemysis@FreeBSD.org>2014-01-16 20:46:13 +0800
commit3a4b34776994055b61b2baeddebff39e49975187 (patch)
tree24c0692499e2e36af8b7367356195ecfb388e240 /games/lostfeathers
parent7b0b5e55ec042b68e6dfa2a1e502fcf8c51e0cca (diff)
downloadfreebsd-ports-gnome-3a4b34776994055b61b2baeddebff39e49975187.tar.gz
freebsd-ports-gnome-3a4b34776994055b61b2baeddebff39e49975187.tar.zst
freebsd-ports-gnome-3a4b34776994055b61b2baeddebff39e49975187.zip
- Change master sites
- Change license BSD to BSD3CLAUSE - Set PORTSCOUT - Change Desktop entry file - Fix the usage of 'python' to get rid of the implicit lang/python dependency - Install missing *.pyc *.pyo, add to pkg-plist - Break lines around 80 characters
Diffstat (limited to 'games/lostfeathers')
-rw-r--r--games/lostfeathers/Makefile25
-rw-r--r--games/lostfeathers/pkg-plist2
2 files changed, 20 insertions, 7 deletions
diff --git a/games/lostfeathers/Makefile b/games/lostfeathers/Makefile
index 4dc6296a46c3..bf14f023229d 100644
--- a/games/lostfeathers/Makefile
+++ b/games/lostfeathers/Makefile
@@ -5,7 +5,7 @@ PORTNAME= lostfeathers
PORTVERSION= 1.0b
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
DIST_SUBDIR= python
@@ -14,7 +14,7 @@ EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Help a bird to recover his magical feathers
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
RUN_DEPENDS= avbin>=0:${PORTSDIR}/multimedia/avbin
@@ -24,12 +24,19 @@ USE_PYTHON= yes
PORTDOCS= README.txt
+OPTIONS_DEFINE= DOCS
+
+# Wrong versioning upstream
+PORTSCOUT= skipv:1.0
+
SUB_FILES= ${PORTNAME}
-DESKTOP_ENTRIES="The Lost Feathers" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" false
+DESKTOP_ENTRIES="The Lost Feathers" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
-OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
+ ${WRKSRC}/run_game.py
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
@@ -41,9 +48,13 @@ do-install:
.for d in cocos data gamelib pyglet
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
- ${INSTALL_SCRIPT} ${WRKSRC}/run_game.py ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+.for f in *.py *.pyc *.pyo
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
+.endfor
+
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/games/lostfeathers/pkg-plist b/games/lostfeathers/pkg-plist
index 3445439b77a2..6d6f6f321678 100644
--- a/games/lostfeathers/pkg-plist
+++ b/games/lostfeathers/pkg-plist
@@ -492,6 +492,8 @@ bin/lostfeathers
%%DATADIR%%/pyglet/window/xlib/xsync.pyc
%%DATADIR%%/pyglet/window/xlib/xsync.pyo
%%DATADIR%%/run_game.py
+%%DATADIR%%/run_game.pyc
+%%DATADIR%%/run_game.pyo
share/pixmaps/lostfeathers.png
@dirrm %%DATADIR%%/pyglet/window/xlib
@dirrm %%DATADIR%%/pyglet/window/win32