aboutsummaryrefslogtreecommitdiffstats
path: root/games/magiccube4d
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-10-08 13:30:52 +0800
committerdanfe <danfe@FreeBSD.org>2004-10-08 13:30:52 +0800
commite017b98a5b8056f98a758a82b1302667ea936617 (patch)
tree5fa6febfb25490d14d1a573a24bd410bdc2385fd /games/magiccube4d
parent4b3a409450ad7b2f51ebab158717d67dd3ee295b (diff)
downloadfreebsd-ports-gnome-e017b98a5b8056f98a758a82b1302667ea936617.tar.gz
freebsd-ports-gnome-e017b98a5b8056f98a758a82b1302667ea936617.tar.zst
freebsd-ports-gnome-e017b98a5b8056f98a758a82b1302667ea936617.zip
Unbreak the build with recent GCC.
Reported by: kris Approved by: portmgr (krion), fjoe (mentor, implicit)
Diffstat (limited to 'games/magiccube4d')
-rw-r--r--games/magiccube4d/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/magiccube4d/Makefile b/games/magiccube4d/Makefile
index 0322e5b7f443..9f114a013694 100644
--- a/games/magiccube4d/Makefile
+++ b/games/magiccube4d/Makefile
@@ -16,17 +16,16 @@ MAINTAINER= karlj000@unbc.ca
COMMENT= MagicCube4D is a four-dimensional analog of Rubik's cube
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION:S/./_/}
DOCS= ChangeLog Intro.txt MagicCube4D-unix.txt \
ideas.txt readme-unix.txt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's/stickers)()/stickers)(0)/' \
+ ${WRKSRC}/EventHandler.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/magiccube4d ${PREFIX}/bin
@@ -37,4 +36,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>