aboutsummaryrefslogtreecommitdiffstats
path: root/games/marsnomercy
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-11-06 04:16:25 +0800
committeracm <acm@FreeBSD.org>2006-11-06 04:16:25 +0800
commit9322f7435b2ba651eed3084c57fd192c3b2449d3 (patch)
tree328a1356ce9f3f605041207b38af269ccc4887c9 /games/marsnomercy
parent6ea64e389b4ec8b2a7999cc375a11487d89e60eb (diff)
downloadfreebsd-ports-gnome-9322f7435b2ba651eed3084c57fd192c3b2449d3.tar.gz
freebsd-ports-gnome-9322f7435b2ba651eed3084c57fd192c3b2449d3.tar.zst
freebsd-ports-gnome-9322f7435b2ba651eed3084c57fd192c3b2449d3.zip
- Update to 0.2.0
- See the ChangeLog at http://www.marsnomercy.org/change.php
Diffstat (limited to 'games/marsnomercy')
-rw-r--r--games/marsnomercy/Makefile17
-rw-r--r--games/marsnomercy/distinfo6
-rw-r--r--games/marsnomercy/files/patch-SConstruct40
3 files changed, 20 insertions, 43 deletions
diff --git a/games/marsnomercy/Makefile b/games/marsnomercy/Makefile
index dcc4297510e3..3b7a874e11d7 100644
--- a/games/marsnomercy/Makefile
+++ b/games/marsnomercy/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= marsnomercy
-PORTVERSION= 0.1.2
-PORTREVISION= 1
+PORTVERSION= 0.2.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mars
@@ -29,7 +28,7 @@ SUB_FILES= mars-nomercy pkg-message
WRKSRC= ${WRKDIR}/mars-${PORTVERSION}
OPTIONS= DEBUG "With additional debug information" off \
- OPENGL "Install binary with opengl support" off
+ OPENGL "Install support for opengl" off
.include <bsd.port.pre.mk>
@@ -43,6 +42,12 @@ SCONS_ARGS+= debug=1
SCONS_ARGS+= debug=0
.endif
+.if defined(WITH_OPENGL)
+SCONS_ARGS+= with_opengl=1
+.else
+SCONS_ARGS+= with_opengl=0
+.endif
+
do-build:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} scons ${SCONS_ARGS}
@@ -58,11 +63,7 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
@${INSTALL_SCRIPT} ${WRKDIR}/mars-nomercy ${PREFIX}/bin
-.if defined(WITH_OPENGL)
- @${INSTALL_PROGRAM} ${WRKSRC}/mars_gl ${PREFIX}/libexec/mars
-.else
- @${INSTALL_PROGRAM} ${WRKSRC}/mars_sdl ${PREFIX}/libexec/mars
-.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/mars ${PREFIX}/libexec/mars
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/games/marsnomercy/distinfo b/games/marsnomercy/distinfo
index 0f23051d30ce..ef985ad68e83 100644
--- a/games/marsnomercy/distinfo
+++ b/games/marsnomercy/distinfo
@@ -1,3 +1,3 @@
-MD5 (mars-0.1.2-src.tar.gz) = 08a4d5d5f20afaf47052ffe4d117f5e8
-SHA256 (mars-0.1.2-src.tar.gz) = aca1dd81e3e6bfffa2d1c0c78c49215be914120c18ea9fc1c31a13aac62442e3
-SIZE (mars-0.1.2-src.tar.gz) = 2450854
+MD5 (mars-0.2.0-src.tar.gz) = 4ad8a9009af5947d6e69159eab47a923
+SHA256 (mars-0.2.0-src.tar.gz) = fde5e8c54e006a1ce6f87c266ebaefaa5ceb3b88c0f7e26a4388fc69e2adbd6d
+SIZE (mars-0.2.0-src.tar.gz) = 2510713
diff --git a/games/marsnomercy/files/patch-SConstruct b/games/marsnomercy/files/patch-SConstruct
index 4031b4f9d3ae..1f220d36363f 100644
--- a/games/marsnomercy/files/patch-SConstruct
+++ b/games/marsnomercy/files/patch-SConstruct
@@ -1,12 +1,13 @@
---- SConstruct.orig Tue Jul 25 03:19:52 2006
-+++ SConstruct Tue Sep 12 18:56:39 2006
-@@ -1,3 +1,5 @@
+--- SConstruct Thu Nov 2 07:10:42 2006
++++ SConstruct Sun Nov 5 14:30:31 2006
+@@ -1,3 +1,6 @@
+import os
+import sys
++
# create build environment and options
env = Environment()
opts = Options()
-@@ -40,12 +42,19 @@
+@@ -40,13 +43,19 @@
# PLATFORM posix or pure cygwin
else:
@@ -20,7 +21,8 @@
+ env.ParseConfig(SDL_CONFIG + ' --cflags')
+ env.ParseConfig(SDL_CONFIG + ' --libs')
# add additional compiler flags
-- env.Append(CCFLAGS = ['-O2'])
+- if not int(env['debug']):
+- env.Append(CXXFLAGS = ['-O2'])
-
+ env.Replace(CC = os.environ['CC'])
+ env.Replace(CXX = os.environ['CXX'])
@@ -30,24 +32,7 @@
# generate help for options
Help(opts.GenerateHelpText(env))
-@@ -53,7 +62,7 @@
-
- # build for debug
- if int(env['debug']):
-- env.Append(CCFLAGS = ['-g', '-O0'])
-+ env.Append(CXXFLAGS = ['-g', '-O0'])
- # of course no stripping if debug
- env['strip'] = 0
-
-@@ -63,20 +72,20 @@
-
- # print all warnings
- if int(env['warnings']):
-- env.Append(CCFLAGS = ['-Wall'])
-+ env.Append(CXXFLAGS = ['-Wall'])
-
-
- # check for libraries and headers (if not cleaning)
+@@ -69,13 +78,13 @@
if not env.GetOption('clean'):
print ":: Checking for libs"
conf = Configure(env)
@@ -64,12 +49,3 @@
print 'Did not find libSDL_ttf, exiting!'
Exit(1)
if int(env['with_opengl']):
-@@ -85,7 +94,7 @@
- print 'Try "scons with_opengl=no"'
- Exit(1)
- else:
-- env.Append(CCFLAGS = ['-DWITH_OPENGL'])
-+ env.Append(CXXFLAGS = ['-DWITH_OPENGL'])
- env = conf.Finish()
-
-