aboutsummaryrefslogtreecommitdiffstats
path: root/games/megaglest/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-08 21:25:26 +0800
committerbapt <bapt@FreeBSD.org>2014-04-08 21:25:26 +0800
commitd7861a5477b3a90aaa1010e8fc5c4026b5621859 (patch)
tree66a0cf9301551333a658c4ca6f45851c22ff27c5 /games/megaglest/Makefile
parent87beb89bea686ef079c59dfcc7aa6a16940edf08 (diff)
downloadfreebsd-ports-gnome-d7861a5477b3a90aaa1010e8fc5c4026b5621859.tar.gz
freebsd-ports-gnome-d7861a5477b3a90aaa1010e8fc5c4026b5621859.tar.zst
freebsd-ports-gnome-d7861a5477b3a90aaa1010e8fc5c4026b5621859.zip
Use wxGTK 3.0
Use lua 5.2 Fix build on headless machines (if help2man is found they it tries to generate a man page for the editor which need display)
Diffstat (limited to 'games/megaglest/Makefile')
-rw-r--r--games/megaglest/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index a534e13cc2ff..63e707925824 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -3,7 +3,7 @@
PORTNAME= megaglest
PORTVERSION= 3.9.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_3.9.0/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
@@ -23,12 +23,11 @@ RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSD
SUB_FILES= pkg-message
-USE_XZ= yes
-USES= cmake dos2unix openal:al,alut pkgconfig
+USES= cmake display:build dos2unix lua openal:al,alut pkgconfig tar:xz
USE_GL= glew gl glu
-USE_LUA= 5.1
USE_SDL= yes
-USE_WX= 2.8+
+USE_WX= 3.0
+WX_UNICODE= yes
CFLAGS+= -I${LOCALBASE}/include/libpng15
WRKSRC= ${WRKDIR}/${PORTNAME}-3.9.0
@@ -39,6 +38,12 @@ EDITOR_DESC= Install MegaGlest Editor
.include <bsd.port.options.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local/include/lua51,${LUA_INCDIR},g ; \
+ s,/usr/local/lib/lua51,${LUA_LIBDIR},g ; \
+ s,lua5.2,lua-${LUA_VER},g' \
+ ${WRKSRC}/mk/cmake/Modules/FindLUA.cmake
+
do-install:
${STRIP_CMD} ${WRKSRC}/source/glest_game/megaglest
@${MKDIR} ${STAGEDIR}${DATADIR}