aboutsummaryrefslogtreecommitdiffstats
path: root/games/meritous
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2010-01-30 17:43:31 +0800
committermva <mva@FreeBSD.org>2010-01-30 17:43:31 +0800
commita7dc1c263e89cfa1f4699fb852a755aa153b2e75 (patch)
tree7123c9d774508d54cd2c680aa6d330596c53df41 /games/meritous
parentf7819f69cd4bca431215e247011f328f936b2300 (diff)
downloadfreebsd-ports-gnome-a7dc1c263e89cfa1f4699fb852a755aa153b2e75.tar.gz
freebsd-ports-gnome-a7dc1c263e89cfa1f4699fb852a755aa153b2e75.tar.zst
freebsd-ports-gnome-a7dc1c263e89cfa1f4699fb852a755aa153b2e75.zip
- Update devel/sdl12 to version 1.2.14.
- Update audio/sdl_mixer to version 1.2.11. - Update graphics/sdl_gfx to version 2.0.20. - Update graphics/sdl_image to version 1.2.10. - Bump portrevisions for all ports depending on audio/sdl_mixer and graphics/sdl_image. - Update Mk/bsd.sdl.mk accordingly for the new shared lib versions. PR: ports/142147 ports/142248 ports/142249 Approved by: miwi (mentor implicit)
Diffstat (limited to 'games/meritous')
-rw-r--r--games/meritous/Makefile2
-rw-r--r--games/meritous/files/patch-src-levelblit.c9
2 files changed, 6 insertions, 5 deletions
diff --git a/games/meritous/Makefile b/games/meritous/Makefile
index aa4870990531..b9b729632c6b 100644
--- a/games/meritous/Makefile
+++ b/games/meritous/Makefile
@@ -7,7 +7,7 @@
PORTNAME= meritous
PORTVERSION= 1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://www.asceai.net/files/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/games/meritous/files/patch-src-levelblit.c b/games/meritous/files/patch-src-levelblit.c
index 631283b75505..bd8ae9d933b7 100644
--- a/games/meritous/files/patch-src-levelblit.c
+++ b/games/meritous/files/patch-src-levelblit.c
@@ -1,11 +1,12 @@
---- src/levelblit.c.orig 2008-01-15 05:54:41.000000000 +0300
-+++ src/levelblit.c 2008-11-24 02:16:34.000000000 +0300
-@@ -27,7 +27,11 @@
+--- src/levelblit.c.orig 2008-01-15 03:54:41.000000000 +0100
++++ src/levelblit.c 2010-01-30 10:07:22.000000000 +0100
+@@ -27,7 +27,12 @@
#include <SDL.h>
#include <SDL_image.h>
#include <assert.h>
-
+
++#include <errno.h>
+#include <unistd.h>
+#include <err.h>
+#include <sys/stat.h>
@@ -13,7 +14,7 @@
#include "mapgen.h"
#include "demon.h"
#include "gamemap.h"
-@@ -378,6 +382,14 @@
+@@ -378,6 +383,14 @@
int main(int argc, char **argv)
{