aboutsummaryrefslogtreecommitdiffstats
path: root/games/monkeybubble/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-08-25 11:01:57 +0800
committeradamw <adamw@FreeBSD.org>2004-08-25 11:01:57 +0800
commit840a815e0d78e62ab4d96422e34a98f58833a6ea (patch)
treeebf75383ab1eefc8d7a72390de20721cf68dbf75 /games/monkeybubble/Makefile
parent185cbd8f49de7ad897d43ae92c8f6da262fb3712 (diff)
downloadfreebsd-ports-gnome-840a815e0d78e62ab4d96422e34a98f58833a6ea.tar.gz
freebsd-ports-gnome-840a815e0d78e62ab4d96422e34a98f58833a6ea.tar.zst
freebsd-ports-gnome-840a815e0d78e62ab4d96422e34a98f58833a6ea.zip
Update to 0.3.2.
Note: there is a sneaking suspicion abounding that this program will not work with libc_r. If you are forcing libc_r for something like the NVidia kernel module, update that port and switch over to libpthread. Note also: a noticible pause when starting a new game seems to be normal. This pause is also associated with a gigantic memory spike, but it'll subside once the game starts.
Diffstat (limited to 'games/monkeybubble/Makefile')
-rw-r--r--games/monkeybubble/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index 82f778ced80f..a9d40f36524e 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -6,29 +6,22 @@
#
PORTNAME= monkeybubble
-PORTVERSION= 0.1.9
-PORTREVISION= 7
+PORTVERSION= 0.3.2
CATEGORIES= games gnome
-#MASTER_SITES= http://monkey-bubble.tuxfamily.org/ #OMG where did the website go?!?!
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= adamw
+MASTER_SITES= http://home.gna.org/monkeybubble/downloads/
DISTNAME= monkey-bubble-${PORTVERSION}
MAINTAINER= adamw@FreeBSD.org
COMMENT= GTK2 Puzzle Bobble clone with monkeys
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix librsvg2 libgnomeui \
- gstreamerplugins intlhack lthack
+ gstreamerplugins intlhack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e "s|gstreamer-0.6|gstreamer-0.8|g" \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>