aboutsummaryrefslogtreecommitdiffstats
path: root/games/monster-masher/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-04-28 20:36:13 +0800
committerkwm <kwm@FreeBSD.org>2005-04-28 20:36:13 +0800
commit8e430fec0774c61d47bf5f2c5885aabdbfae9afd (patch)
tree730dd5289ff8b6a2e057ce6b4b6d9b2289ca361b /games/monster-masher/Makefile
parentd6367b90d8e67b5e59c20289af2f5604e0a66642 (diff)
downloadfreebsd-ports-gnome-8e430fec0774c61d47bf5f2c5885aabdbfae9afd.tar.gz
freebsd-ports-gnome-8e430fec0774c61d47bf5f2c5885aabdbfae9afd.tar.zst
freebsd-ports-gnome-8e430fec0774c61d47bf5f2c5885aabdbfae9afd.zip
Update to 1.7.
Fix typo in LDFLAGS so gettext is found. Mark ignore on 4.x, its freezes when starting a new game. Patches are welcome.
Diffstat (limited to 'games/monster-masher/Makefile')
-rw-r--r--games/monster-masher/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index a3faa92dafab..49f925430dba 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= monster
-PORTVERSION= 1.6.1
-PORTREVISION= 2
+PORTVERSION= 1.7
CATEGORIES= games gnome
MASTER_SITES= http://www.cs.aau.dk/~olau/monster-masher/source/
PKGNAMESUFFIX= -masher
@@ -16,7 +15,7 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Gnomemm puzzle game where you have to clean the caves of monsters
-LIB_DEPENDS= gnomeuimm-2.0:${PORTSDIR}/x11-toolkits/libgnomeuimm
+LIB_DEPENDS= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26
USE_X_PREFIX= yes
USE_BZIP2= yes
@@ -24,13 +23,14 @@ USE_GNOME= gnomeprefix gnomehack gnometarget intlhack
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASA}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= monster-masher.schemas
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500010
+IGNORE= Freezes when starting a new game
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-vector.hpp
.endif